Jump to content
  • Forum Statistics

    3,736
    Total Topics
    30,904
    Total Posts
  • Member Statistics

    100,561
    Total Members
    16,800
    Most Online
    rsaalfrank
    Newest Member
    rsaalfrank
    Joined

DAANY

Members
  • Content count

    4
  • Joined

  • Last visited

  1. I have contacted the support team and they have sent me a new controller, since then the software started to recognize the fans. Problem solved
  2. I have windows 10 as OS System specs i5 6500, 16gb ddr4 RAM, 960 gb SSD, Asrock b150/k4 motherboard, 650 w Bronze Fractal PSU, EVGA GTX 1070 FTW. I have always turned off the computer and plugged the fans or unplugged them. Still the software seems to not recognize the fans
  3. Hey Bou87, I have the same problem, I dont seem to find the solution yet. Please let me know if you figured out the solution. Thankyou.
  4. I recently bought the Riing 12 RGB Fan TT Premium Fan pack. I have installed the fans in case connected each fan to the hub, connected to molex and connected it to my motherboard using usb 2.0 connection. After installing the software, i noticed none of the fans are being recognized by the software. I have un installed the software, connected to a different usb connection, only connected 1 fan on the hub, even changed my entire ssd, still the fans are not being recognized by the software. Though my motherboard is new i thought it was the usb connection fault, so i tried the nzxt hue + lightning kit on both connections and it worked and i can control it form my pc. Should i return the fans or is there any other trouble shooting i can do. Please leve your suggestions Thankyou.
×