• Forum Statistics

    2,996
    Total Topics
    26,841
    Total Posts
  • Member Statistics

    121,286
    Total Members
    16,800
    Most Online
    rebeca.berreca@gmail.com
    Newest Member
    rebeca.berreca@gmail.com
    Joined

pj8847

Members
  • Content count

    6
  • Joined

  • Last visited

  1. Already answered in post #140 "As I said, 6 machines with win 10 pro x64... all have same problem, even on a complete reformat and fresh install." Guess I just have to toss it in the trash or hand it off to someone I know who uses win 7 and go with a different company. Shame, spent good money on it and it was a good mouse; works flawlessly in win 7, never worked properly in any version of win 10 though and doesn't look like it ever will.
  2. Doubt it, as I said previously, everything works as it should using win 7 pro & Ult x64. No problems with mouse itself. it's definitely the software and something in conjunction with win 10 X64...
  3. As I said, 6 machines with win 10 pro x64... all have same problem, even on a complete reformat and fresh install.
  4. I've tried everything from the original version that came with the mouse all the way up to the linked 1.0236 files... No difference, same exact thing.
  5. Is there any update to this problem with the mouse not being recognised and the software not running? I haven't seen anything but "we are escalating the issue" over and over again in multiple posts, but not one update since, and these posts go back to july of 2016... and beyond. $70+ piece of hardware that it's own software doesn't recognise, Including the "firmware update"... this is rediculous. Problem exsist for me on win 10 pro x64 platform, on every rig I try it on (total of 6 I own) and it is the same on every one. Mouse is only recognised by windows as an "HID-Compliant device", no control over the different buttons/keys, lighting, sensitivity, etc without the software and the software won't find it; keeps asking me to "plug in device" and I have done so over and over again in multiple USB ports with no change.. I'm stuck with a $70+ basic mouse. Please do something about a proper driver for this or lets talk about a refund of my purchase. I could have spent $10 bucks for a basic mouse if that's what I wanted... (NOTE) mouse and software work fine on win 7 pro x64 platform, so obviously its a win 10 driver issue ( which there appears to be no driver available?), please do something about this already, it's been long enough...
  6. Is there any update to this problem with the mouse not being recognised and the software not running? I haven't seen anything but "we are escalating the issue" over and over again in multiple posts, but not one update since, and these posts go back to july of 2016... $70+ piece of hardware that it's own software doesn't recognise, Including the "firmware update"... this is rediculous. Problem exsist for me on win 10 pro x64 platform, on every rig I try it on (total of 6 I own) and it is the same on every one. Mouse is only recognised by windows as an "HID-Compliant device", no control over the different buttons/keys, lighting, sensitivity, etc without the software and the software won't find it; keeps asking me to "plug in device" and I have done so over and over again in multiple USB ports with no change.. I'm stuck with a $70+ basic mouse. Please do something about a proper driver for this or lets talk about a refund of my purchase. I could have spent $10 bucks for a basic mouse if that's what I wanted... (NOTE) mouse and software work fine on win 7 pro x64 platform, so obviously its a win 10 driver issue ( which there appears to be no driver available?), please do something about this already, it's been long enough...