Jump to content
  • Forum Statistics

    3,734
    Total Topics
    30,902
    Total Posts
  • Member Statistics

    101,828
    Total Members
    16,800
    Most Online
    rsaalfrank
    Newest Member
    rsaalfrank
    Joined

EasyLover

Members
  • Content count

    4
  • Joined

  • Last visited

About EasyLover

  • Rank
    Beginner

Recent Profile Visitors

79 profile views
  1. Command Center Pro not loading

    I have got Challenger Edge Pro and Nemesis Mouse. Command Center Pro for the Nemesis is installed but not loading up no matter what I do. Tried it on 3 different Systems but same result. Removed all HID instances in the device manager but no effect. Even install the fresh Windows but no effect. It is Windows 10 btw.
  2. I have got Challenger Edge Pro and Nemesis Mouse. The software for the Challenger Edge Pro is loading but not recognizing the keyboard and all I am getting is No Device on the main screen. Tried it on the second PC but the fate was the same.

    Command Center Pro for the Nemesis is installed but not loading up no matter what I do. Tried it on 3 different Systems but same result. Removed all HID instances in the device manager but no effect. Even install the fresh Windows but no effect. It is Windows 10 btw.

  3. Which version of the windows you are using? Command Center Pro is not loading on my PC with Windows 10. Tried it with 3 PCs but same fate.
  4. Challenger Edge Pro

    I am having same problem on windows 10.
  5. Prediction Voting Event

    JP Modified. Jesse Palacio has my vote.
×