Jump to content
  • Forum Statistics

    3,255
    Total Topics
    27,707
    Total Posts
  • Member Statistics

    124,203
    Total Members
    16,800
    Most Online
    FollowX
    Newest Member
    FollowX
    Joined

sniperdoc

Members
  • Content count

    1
  • Joined

  • Last visited

  1. Level 10 GT Series Owner's Club

    Just wanted to check in on this, so that other Level 10 GT users would be aware. When I use the front panel headphone jack from the case, I had major interference from the entire system. I am running the following: Processor: Intel Core I7-6700K @ 4GHzCooler: Corsair Hydro Series H90Motherboard: MSI Z170A XPower Gaming Titanium EditionRAM: Corsair Dominator Platinum 16GB DDR4 24000 (CMD16GX4M2B3000C15)PSU: Corsair HX850 850W 80PLUSGPU: MSI GTX 980 Gaming 4G LESound: SB Recon3D Fatal1ty ProOptical: Samsung SH-222BB/BEBEHDD0: OCZ Trion 150 SSDHDD1: WD Velociraptor 300HDD2: WD Raptor 150HDD3: Seagate 1TBHDD4: Seagate 1TBOS: Windows 10 Pro 1607Case: Thermaltake Level 10 GT (best case ever)Battery Backup: APC 1500VA LCD I plugged the correct front panel audio connector into the SB sound card. If I used the headset on the front panel I would hear my mouse moving. I would hear the GPU cycles, CPU cycles... it as very audible, but livable if I was gaming. If I plugged in my mouse and keyboard on the front panel, the noise would amplify ten-fold. Since I recently had to take a part my system for a rebuild, I checked out some resources online and found this: https://www.techpowerup.com/forums/threads/article-fix-front-panel-audio-emi-noise.187276/ This fix worked like a charm! It's like I have a whole new sound system! Everything is so CLEAR!!!! I hear things I've never heard before! Hopefully this will help some folks in the future.
×