Jump to content
  • Forum Statistics

    3,341
    Total Topics
    28,149
    Total Posts
  • Member Statistics

    124,447
    Total Members
    16,800
    Most Online
    feeee
    Newest Member
    feeee
    Joined

Davide

Members
  • Content count

    3
  • Joined

  • Last visited

About Davide

  • Rank
    Beginner

Profile Information

  • Gender
    Male
  • Location
    Italy
  • Interests
    Pc Gaming
  1. Meka G1 annoyng problem

    You are right... The problem is not the kb but the mobo. I will wait a next new Bios update with the hope it can solve this issue. Thanks a lot for your support David.
  2. Meka G1 annoyng problem

    Hi David, yes the keyboard work on other computer. Another singulatity is that the keyboard not work when I remove the Ac power cord. If shutdown but not remove Ac power it work great. At this point I presume it's a strange incompatibility between kb and my x370 mobo. I have no other ideas...
  3. Meka G1 annoyng problem

    Hi guys, I have an annoyng problem with my meka g1 an my new ryzen configuration (AsRock x370 fatl1ty k4 + r5 1600). At startup of pc the keyboard is not detected, nothing works and I can't also access to BIOS, I must unplug the usb cable and plug it again to see keyboard's led power on and use it. I try to change usb port (rear and front), update chipset, update BIOS to last version, delete standard driver an reinstall it but nothing change, the strange thing is that the other usb peripherals like printer or mouse works great, only meka have this behavior. Someone have a similar situation or solved this. I hope in your support Thanks. P.S: sorry for my english....
×