Jump to content
  • Forum Statistics

    3,734
    Total Topics
    30,902
    Total Posts
  • Member Statistics

    101,829
    Total Members
    16,800
    Most Online
    rsaalfrank
    Newest Member
    rsaalfrank
    Joined

teddyb

Members
  • Content count

    5
  • Joined

  • Last visited

  1. DPSG software not working.

    I have a similar issue. My software will not open. It just says "device not detected". Does this work through the ATX cable?
  2. Riing TT Premium Edition RGB LED Fans - How to Videos

    I returned my unit because it would not work with my Ryzen CPU - Floe Riing 240. I advise people with Ryzen to not get this cooler. I talked with TT support and they confirmed issues with software and Ryzen as well.
  3. I was drawn in by the shiny lights and bright colors. I should have known better. TT Floe Riing 240 does not work with Ryzen CPUs and TT will not tell anyone this until after you buy it. The software is a mess and there is no fix in sight. Whenever I try to use the software my PC fans rev up full blast and my PC shuts down. I talked with tech support about this and they know about the issue!@@####. I am returning my unit and suggest anyone with a Ryzen CPU do the same!
  4. Big disappointment. I am returning mine.
  5. I am having similar issues with Riing Floe 240 RGB and the software. When I start the software my fans start going full speed and then my PC crashes. I have had stable OC at 4ghz (from 3.2ghz Ryzen 1600) and can run DOOM at Ultra settings with stable low temps so I know that my system does not NEED to go that fast with the fans. Seems like a software issue to me and as others are saying a "Ryzen-specific" issue. Hoping to get this solved quickly. Any suggestions? My system says that C++ distro install failed (because I have a newer version of that software already installed so it should be fine?) Also, I had issues when I plugged in the Riing Floe to my board AIO_pump header so I kept it on CPU_FAN and it works fine (minus lights software issue). I have heard plugging the fans into an outside USB port works so I suspect the issue is a bad TT fan controller and the USB glue issue is to blame on this. Hopefully, TT can give me a replacement controller to get the software working. - Please help get me in touch with TT! I guess I need a new replacement controller? - maybe USB issue as mentioned before? Product: Riing Floe 240 RGB System: Ryzen 5 1600 16gb DDR4 2400 RX Vega 56 Asus B350 ROG STRIX Mobo TT older fans in case (RGB) w/ older controllers (non-usb controllable) case: Thermaltake View 31
×