Jump to content

Search the Community

Showing results for tags 'Duet Docking address failed'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • LUXA2 Thermaltake Mobile
    • Power Bank Solution
    • Holder Solution
    • Audio Solution
    • Accessories
    • LUXA2 General Discussion
    • FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Calendars

  • Community Calendar

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Found 1 result

  1. Running Windows 8.1, I purchased 2 BlackX 5g Duet docking stations. Could not get the first one I tried to recognize for anything. Tried the second one and it worked great! Looked like a DOA of the first dock so I returnede it and ordered another. The replacement came in, I plugged it in (keep in mind I have a working dock right now already attached to the system), Device Manager eventually show the device as "Unknown USB Device (Set Address Failed)". Doesn't show in Disk management either. I found one solution that required a small Windows update on Windows 8 to get this to work. Even though I already had one working, I downloaded and ran the update. It said it was installed already and exited. I can't seem to find any help on this online other than other posts relating to the same issue. I checked the Thermaltake support page, it's Sunday and the phone support is only available M thru F which dosn't help me, the Chat option says its coming in the future, ugggh, and the email support page is a bad link! So no support for me. So I am raching out to the forum to hopefully find my solution. I understand the address issue, but also understand it will be a reg hack to prob fix it. I was hoping for some other insight before I proceed further. Thanks in advance!!
×