Search the Community: Showing results for tags 'Ryzen'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • LUXA2 Thermaltake Mobile
    • Power Bank Solution
    • Holder Solution
    • Audio Solution
    • Accessories
    • LUXA2 General Discussion
    • FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Calendars

  • Community Calendar

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Found 3 results

  1. Just wondering if anyone has fixed the issue everyone is having with Ryzen compatibility? I know my controller cable is connected proper, I hear a connected tone from Windows. It also says USB device has been connected and ready for use. However, when I try to open the program. It is listed in my task manager, and the icon on the bottom right is showing. But beyond that, nothing happens. Program opens when I disconnect the controller cable, found this out from these forums. But of course it says nothing is connected. I've messaged the admins myself, waiting on a response. But anyone with more information, I would greatly appreciate it. Thanks everyone for the time. - Frustrated Riing Plus 12 user
  2. To all Ryzen and Riing Plus owners. 1. There is a workaround so the Riing Plus software will load and you can start making profiles. Connect the controller using a Micro-USB cable to a USB port on the back of your motherboard. This will allow the software to load. Notice, not all ports work for everyone, so try more that just one. 2. Please like this post, and request support (here: http://my.thermaltake.com/csTech.aspx) so thermaltake can start noticing the Ryzen users. This bug needs to get fixed SOON!! it has been more than TWO months!! BTW. I did send a request but did not get "a satisfactory response within 24/48 hours " I got nothing yet. So post below if you did request support and post your replay if you get any. Thanks.
  3. I built a new system featuring the FX-8350 this past summer and I purchased the pacific r360 kit for it. With the release of AM4 around the corner, I was wondering if thermaltake's Pacific W1 waterblock will have support for it, and if not - will they sell or give us mounting brackets? Or will we just have to buy a new block...?