Search the Community: Showing results for tags 'issue'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • LUXA2 Thermaltake Mobile
    • Power Bank Solution
    • Holder Solution
    • Audio Solution
    • Accessories
    • LUXA2 General Discussion
    • FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Calendars

  • Community Calendar

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Found 10 results

  1. Hello! I just got my keyboard yesterday and downloaded the software off of the Tt Esports website for this keyboard. It works fine, I'm using it to type this post right now. The issue I'm having is whenever I try to open the applications KBOption.exe or KBHid.exe to try and create macros and different keybindings. Whenever I try to open the applications, they seem to open for a moment but then they instantly close down. The processes in task manager tell me that the process is working as well as the driver, but the applications themselves aren't working. They are allowed through my firewall with a specialized exception and the process is set to run with start up. I'm not sure what the issue is and any help would be greatly appreciated! Thank you!
  2. So I've had this keyboard for nearly a year now ( bought it mid january last year ) and i am in love with it. I use it to play Multiple games including cs go and it has been a flawless keyboard for such a long time. I have ran into 2 issues with this keyboard recently and they are very VERY bad issues when playing CS:GO Issue Number 1 : I've had this problem for quite some time now, but I've been trying to avoid it as much as possible which is a hard thing to do. The "G" key will be pressed once, and it would end up registering as 2 presses instead of one. In CS:GO, the G key is used to drop weapons and the Bomb. I sometimes drop the bomb when i start with it which also drops my GUN and forces me to run and pick it up. Issue Number 2 : The CTRL button works maybe 30% of the time, and even when it does work, (holding it down) it wont be registered as me holding it down. In CS:GO, the CTRL button is used to crouch. If you are familiar with CS:GO, you would know how detrimental hopping up and down from crouching is in a gunfight. I know this keyboard came with a 5 year warranty, does the warranty cover these issues listed above? Like I said this keyboard is amazing, but if i have to end up replacing it with another brand, that would be upsetting because of how much i am in love with how simple the keyboard looks. Also you can see how nice it matches my setup here
  3. Hello. I bought this keyboard around a month ago and so far I've been liking it a lot. Although the switches are made by Kailh which I didn't know (the page says they're tt esports switches) so far I haven't really noticed a difference since it's my first time trying brown switches. I do have to say I expected them to be clickier, but them being so quiet is also nice. I have had, however, a few problems with the software and function keys: Software related:I've used 3 versions of the software thus far. Firmware 48: -fully lighted: works well but the medium speediness for both pulse and spectrum circling doesn't work. -reactive: works fine -wave: speediness doesn't work at all -arrow flow: speediness doesn't work at all and it's painfully confusing to set up -ripple: same as arrow flow Firmware 0: -fully lighted: works well but the medium speediness for both pulse and spectrum circling doesn't work. -reactive: works fine -wave: speediness works except the last setting, which is glitched on the keyboard. Doesn't go past half the keyboard before resetting -arrow flow: speediness doesn't work at all and it's painfully confusing to set up -ripple: same as arrow flow Firmware 40: -fully lighted: spectrum circling behaves oddly. Instead of making a smooth color transition, it appears to change colors in ticks, every tick changing the color a bit more -reactive: works fine -wave: works fine -arrow flow: works fine -ripple: works fine Function keys related: -N-key rollover disables itself -brightness doesn't work at all in non-reactive modes (but it works on breathing mode) -gaming mode key will sometimes trigger a lightning glitch while on spectrum circling mode, where the lights will shift back to the beginning of the circling while transitioning colors. Switching modes back and forth fixes this Other than this the keyboard works fine, but I'm not satisfied with how the software turned out to be. It's lacking effects other RGB (and even non-RGB) keyboards have and it's quite disappointing. I'd like to know 2 things based on this: how can I fix these problems from happening, if possible, in the latest firmware update? is the software going to be updated, adding new effects?
  4. I recently bought the cronos ad headset and when I say recently i mean yesterday it arrived i opened the package this morning plugged them in and they didn't work what should I do? by the way I have set them to default,I updated drivers,I tried to disable and enable them,I even restarted my computer,I replugged them in The only thing i can think of is either a) the headphones are broken b my computer is broken Edit: I think its from the headphones i plugged them in my phone and they still didn't work
  5. hello, I bought a theron mouse in a few month ago and I read in the product page that I can change my mouse light color so I download the mouse app in my computer but the problem is when I open the app and click on light option the what I see: http://prntscr.com/c1ihy0 note my mouse cod: trn006dtmhf001858 I hope some one can help me!
  6. Hello, I bought Thermaltake Urban T81 PC Full Tower Case. After 2 months the fans stopped to work. I was so afraid that they are died. But when I disconnected them from the fan hub that included on the case and just connect them directly on motherboard they worked fine. I would like to ask you kindly, could you please send me a new fan hub and thank you. If you accept and it will be appreciated I will give you my address.
  7. So, i have had this thermaltake 1200 watt toughpower PSU since late 2014, but something funky seems to be happening with it. What I need help with is determining if my problem is the PSU's fault, so thats why Im writing here. There are two problems: first, sometimes and randomly, my computer will fail to boot up. I press the power button, the system powers up for approximately a second, and then immediately shuts down without even opening the BIOS screen. It then stays off for around 5 seconds then turns on again for another single second, and the cycle continues ad infinitum. There is no anticipating this problem, and the only way to stop the power cycling is to unplug the computer. The second, and perhaps related (or maybe not) problem is found in my video card, and it is my suspicion that it is caused by the PSU. I have two XFX Double Dissipation Radeon R9 290X vid cards in a crossfire configuration. When I built this rig, I made sure to properly power the vid cards, having asked XFX what the minimum requirements and their suggestion for power was ( 1000w PSU minimum, 1200w recommended). So, the cards should have enough power, but I only ever see one, either in device manager or in the BIOS. Both cards have their lights and fans functioning, I have triple checked all wiring, and have checked the cards themselves by testing their functionality separately and independently. So, what do you guys think? Is it the PSU that might be causing these problems? Could the PSU be malfunctioning? How do I test the PSU for its functionality? Thanks for any CONSTRUCTIVE input. -LD
  8. i bought a SAPHIRA OPTICAL GAMING MICE, connected to pc, installed drivers etc. everything is ok, but today i noticed a bug on my wheel. its like while im using wheelup 2-3 times its going down, if i use down its going up. i have warranty,invoice etc. but idk its a bug,problem or something like this, or its a feature for game how can i fix it ? or can i change my mouse with new one ?
  9. As a big fan and user of the original Theron mouse, I recently decided to purchase the more updated edition, the Theron Plus. On my previous model I had the macro button on the right hand side of the mouse bound to the key-press of the Scroll Lock button. The idea being that pressing the macro would key-down on scroll lock and releasing would key-up on scroll lock. The macro worked perfectly on the old setup and I was looking forward to using the newer model in exactly the same way, but unfortunately there seems to be some subtle differences in the way the macro works. Here's my setup for my original Theron mouse. This acts exactly how I want, pressing the macro button on the mouse directly corresponds to the key-up and key-down events of scroll-lock This is the setup for the new Theron Plus mouse. As you can tell, it's setup identically, but yet the function is different. Instead of the macro directly corresponding to scroll lock's key-up and key-down, the macro in the Plus version key-up and key-downs many times within me pressing the macro button. It acts much like as if it were setup like this: I appreciate the fact the software changes to be more intuitive, but through trial-and-error I've found no discernible solution to my problem. I would like to reach out to the community and the Tt eSPORTS support team for help regarding the issue. If you feel that my post doesn't communicate the issue and leaves you confused, or need further information, feel free to post below and I'll be more than happy to provide the information to get this issue sorted out. Thanks.
  10. Hi, i recently just bought my Challenger Prime and started programming macros and keys and all that stuff. But then i noticed if you change stuff 3 times the software will just say please wait... because its changing but it never finishes and i end up closing it with task manager. So when i start it up again i try to change one thing after that i cannot do it because then it will say please wait... again... So i uninstalled it and re installed it then it works... for 3 more times... Dunno if this is a bug or something but i don't know how to fix it. Can someone please help me? Thanks! ANYONE PLEASE HELP THANKS