Search the Community: Showing results for tags 'spm software problems'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • LUXA2 Thermaltake Mobile
    • Power Bank Solution
    • Holder Solution
    • Audio Solution
    • Accessories
    • LUXA2 General Discussion
    • FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Calendars

  • Community Calendar

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Found 1 result

  1. Hey Guys! I just received the Thermaltake Toughpower Grand DPS G 850 W 80Plus Platinum and after installing the SPM software and start the software up, it just loads a white screen. Everything else seems to be working perfectly but the SPM software, not totally sure what is wrong. Any help is greatly appreciated!! I'm also attaching a picture of what I see when I run the SPM software: Thanks again in advance!!! Edit: Just noticed someone else has this problem and posted about it a few days ago: http://community.thermaltake.com/index.php?/topic/40768-problem-with-dps-app-for-dps-g-650w-gold/