Jump to content

Search the Community

Showing results for tags 'windows 10'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • LUXA2 Thermaltake Mobile
    • Power Bank Solution
    • Holder Solution
    • Audio Solution
    • Accessories
    • LUXA2 General Discussion
    • FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Calendars

  • Community Calendar

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Found 5 results

  1. Hi Community! I've recently bought the ThermalTake Poseidon Z RGB (Cherry Brown) and I had installed the software and set it up perfectly on my Windows 8 Pro machine. I had tested all lighting functions within the Effect Control section of the software (Fully Lighted, Reactive, Arrow Flow, Wave and Ripple) which worked beautifully. Although from what it seems now, after updating to Windows 10, the lighting on the keyboard is either non-existent or seems like it's got a mind of its own. >> Here's a quick summary of issues: - There are no longer any proper full colours displaying (Red, Blue, Green, Yellow etc) - it's all very light colours depending on the effect control set - The programming behind setting a Effect Control function seems to apply, but the lighting is complete screwed. Eg: Certain areas of the keyboard light up, some appear randomly and are also inconsistent. Like stated above, a mind of its own - The key that disables the Windows key (Button above the keypad - 2 arrows) makes the keyboard light up crazily. The light display outcome is always different. When pressed, a lot of times the light will display around the keypad area - I had to plug and unplug my keyboard multiple times for it to even detect on the pc - The second time I had updated the firmware to 36 from 30, the lights aren't even displaying at all when changing Effect Controls. I've manually reset it a few times, still to no avail. >> Further Testing: - After testing thoroughly for another 30 minutes, I've managed to somehow not display any colours at all on the keyboard no matter what Effect Control function I select. Resetting it brings the keyboard back to Red, but after choosing an effect, all colours disappear. Also refer to my 'Settings' attachments to see how it looks like. >> What's been done that didn't resolve the issue: - Re-installing the software several times, updating firmware etc - Fn+Esc hardly works, I have to manually click the Refresh button within the software to no avail - Removing the keyboard device and trying different USB ports I have a 40 second clip which shows the incorrect colours but is too big to attach. If you require it, please let me know the best way I can display it accordingly. Thanks. - Wilfred.
  2. CHALLENGER Pro Driver for Windows 10

    Hi all, I have the issue with keyboard Challenger Pro. Cannot run software on win 10 (64 -bit). I have tried all compatibility modes + run as administrator, but w/t any success. The GUI even doesn't start. However, I can see the process in Task Manager. Has anyone run into the same problem? How can I fix it? TIA!
  3. I built a system with a Asus Z170 Pro Gaming motherboard. I hooked power up the power cable for the docking station and ran the sata connector to one of my sata ports on my mother board. The hot swap feature of the docking station isn't working. It will read the drive on a system reboot but no hot swap. I tried sticking the sata cable into one of the sata express ports on my motherboard but that didn't work either. The manual says to activate the AHCI function on my mother board but I couldn't find an option for that when I ran Bios, maybe it comes preset? I am running Windows 10 Pro Full version 64 bit. This was the main reason I chose this particular case and it isn't working. Someone please help me!? Thanks!
  4. Hello. I have had my new pc for about 3 weeks with no troubles. last week the mouse started cutting out. are there drivers i can install for this mouse? something? thankyou for any help you can provide:)
  5. I just bought the CHALLENGER Prime and tried to install the software of it on Windows 10 but it gave me a bunch of errors and it didn't install. The keyboard is working fine though and I configured my keyboard on a laptop running Windows 8.1.
×