Jump to content
VasiaPupkin

Program doesn't launch now

Recommended Posts

I had to reinstall Windows before. Then I installed Tt eSPORTS BLACK Element series_AP V1.0.0.2. It worked fine. Then I installed all the drivers for my ASrock H61M-VG3 motherboard. And now I cant launch TT software to customize my mouse settings.

 

Jr3kLKB.png

 

Before changing Windows everything worked fine with the same drivers.

Share this post


Link to post
Share on other sites
Guest Tt Josh

I had to reinstall Windows before. Then I installed Tt eSPORTS BLACK Element series_AP V1.0.0.2. It worked fine. Then I installed all the drivers for my ASrock H61M-VG3 motherboard. And now I cant launch TT software to customize my mouse settings.

 

Jr3kLKB.png

 

Before changing Windows everything worked fine with the same drivers.

Hi VasiaPupkin, nice to have you here!

 

We'll escalate the issue to our Product Management team and will keep you updated! ;)

Share this post


Link to post
Share on other sites

Hi, I have exactly the same problem.

When I bought and installed the mouse it all worked fine. I reinstalled the system, installed the drivers again and I have the same message

The mouse is working but the configuration menu doesn't start and keeps asking me to plug in my device

Please help

Thanks

Share this post


Link to post
Share on other sites

Hi Josh,

thank you for your reply. It looks like the mouse is working properly but is not listed as Thermaltake mouse in device manager, therefore, I can only install the main driver, but cannot install anything else as the system doesn't see it.

It seems to be installed as an ordinary, system mouse (however in the control panel there is a hardware called Tt eSports Black Element) All the buttons and wheel work with no problems, I just cannot open the main software to change any settings

I'm a bit lost because I had no problems with the software before reinstalling the Windows and I had all the same drivers- I didn't change any hardware in my computer

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi Josh,

thank you for your reply. It looks like the mouse is working properly but is not listed as Thermaltake mouse in device manager, therefore, I can only install the main driver, but cannot install anything else as the system doesn't see it.

It seems to be installed as an ordinary, system mouse (however in the control panel there is a hardware called Tt eSports Black Element) All the buttons and wheel work with no problems, I just cannot open the main software to change any settings

I'm a bit lost because I had no problems with the software before reinstalling the Windows and I had all the same drivers- I didn't change any hardware in my computer

Glad to know that the mouse is working, but for the software, you can try to uninstall the software for BLACK ELEMENT and reinstall the one provided to you and see what happen!

 

Keep me updated! ;)

Share this post


Link to post
Share on other sites
Guest Tt Josh

michallesio

It's easier to reinstall Windows and all the programs than wait for TT help.

 

Tt Josh,

thanks, Captain.

Great to hear that VasiaPupkin! Fire us a message if you need any assistance! ;)

Share this post


Link to post
Share on other sites

I've got all the files you attached to your reply Josh. Like I said I can only install the main file but the mouse is not properly listed after the installation (and after restarting PC) so I cannot update the firmware or install anything else as the programs do not see it, even if the mouse works ok

Share this post


Link to post
Share on other sites
Guest Tt Josh

I've got all the files you attached to your reply Josh. Like I said I can only install the main file but the mouse is not properly listed after the installation (and after restarting PC) so I cannot update the firmware or install anything else as the programs do not see it, even if the mouse works ok

Hey michallesio, can you take a screenshot for us to see how it's not properly listed after the installation? ;)

Share this post


Link to post
Share on other sites
Guest Tt Josh

Click on "More Reply Options" right next to "Post" and you can attach your screenshot! ;)

Share this post


Link to post
Share on other sites
Guest Tt Josh

post-1609-0-91587900-1428573296_thumb.png

 

Hey michallesio, try to uninstall the "unknown device" from your device manager and install again.

 

Keep us updated! ;)

Share this post


Link to post
Share on other sites

I tried to do it many times. The device remains unknown after uninstall and restart. I've been trying to let windows to find drivers automatically and to show the folder with thermaltake drivers installed manualy-nothing works

I've been uninstalling thermaltake software many times, restarting pc each time, installing them again and again. Mouse works, software doesn't and doesn't see the device either

Share this post


Link to post
Share on other sites
Guest Tt Josh

I tried to do it many times. The device remains unknown after uninstall and restart. I've been trying to let windows to find drivers automatically and to show the folder with thermaltake drivers installed manualy-nothing works

I've been uninstalling thermaltake software many times, restarting pc each time, installing them again and again. Mouse works, software doesn't and doesn't see the device either

I'll escalate the issue to our Product Management team and will get back to you once they have the solution! ;)

 

Sorry for the inconvenience!

Share this post


Link to post
Share on other sites

      hello Im haveing the very same issue with my Ventus mouse software i have widows 8 pro 64 bit  ive tryed everything i can think of and nothing the software worked till after i installed my razor key pad than it stoped working the mouse and buttons work fine  if any one can help i just want to speed up my mouse i play on a 52 inch lcd and it creeps across the screen if not looks like i wasted money and will buy another mouse but not this brand

Share this post


Link to post
Share on other sites
Guest Tt Josh

      hello Im haveing the very same issue with my Ventus mouse software i have widows 8 pro 64 bit  ive tryed everything i can think of and nothing the software worked till after i installed my razor key pad than it stoped working the mouse and buttons work fine  if any one can help i just want to speed up my mouse i play on a 52 inch lcd and it creeps across the screen if not looks like i wasted money and will buy another mouse but not this brand

Hey Vigourouss! try to install the software below for your VENTUS mouse:

 

TT ESPORTS VENTUS SOFTWARE V1.1_ENGLISH

 

If it's still unresolved, please tell us which country you're from and we'll assist you further! ;)

Share this post


Link to post
Share on other sites

Hi, 

 

I think I have the same problem too

Same ASrock  motherboard, windows 7 service pack 1

I bought a level 10 m mouse yesterday ,  I plug the mouse to my computer. Windows can recognize the mouse tt esports level 10m , but no driver found. After I installed the software , still show no driver found.

 

I have tried different USB port.

re-install the software listed in tt esports website.

remove the hardware in device manager, and restart the computer.

 

I think it is driver problem as after I remove the hardware in device manager, and restart the computer, the mouse can be use, however after the windows can't found the driver, the mouse can't use again. 

 

Please help. thanks

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi, 

 

I think I have the same problem too

Same ASrock  motherboard, windows 7 service pack 1

I bought a level 10 m mouse yesterday ,  I plug the mouse to my computer. Windows can recognize the mouse tt esports level 10m , but no driver found. After I installed the software , still show no driver found.

 

I have tried different USB port.

re-install the software listed in tt esports website.

remove the hardware in device manager, and restart the computer.

 

I think it is driver problem as after I remove the hardware in device manager, and restart the computer, the mouse can be use, however after the windows can't found the driver, the mouse can't use again. 

 

Please help. thanks

Hey DKYLC, did you try it on another computer? you can try to check whether it works on another computer.

 

Also kindly provide us the country you're from, we'll get our local staff to assist you further ;)

Share this post


Link to post
Share on other sites
Guest Tt Josh

hi,

 

Not , I have no other computer. I think is the problem of driver.

 

I come from Hong Kong.

 

Thanks,

Hey DKYLC, please contact our Customer Support at cs2@thermaltake.com and we will have our Customer Support staff to assist you further! ;)

 

Please include the below information in your email:

 

- Your name

- Your email

- Your contact number

- Your country

- Description of the issue

- Product number

- Product name

- When did you purchased the product

- Where did you purchased the product

 

Keep me updated! ;)

Share this post


Link to post
Share on other sites
It's bug of TT software, not our systems. I reinstalled Windows and all the programs. Now it works fine.
 
I bet, TT will never fix that. All they can do is "escalate the issue to our Product Management team".
 
Easier solution is to reinstall Windows. I tried to clear out all the TT drivers and programs and install TT software again then. Didn't work. Then I deleted all possible drivers and software that I installed after system installation. Didn't help again.
It's not about any software conflict. It's about buggy software.

 

BTW, for what there's timer?
yLY2tm7.png
 
And there's other bug with TT software. May I make new topic about that or it has quick solution?
 
When it's launched, all the windows in system drags without content. And they begin to work fine after closing TT application. Here's gifs:
 
Launched:
opMuVjR.gif
 
Closed:
u97IfhA.gif
 
P.S. I'm fully satisfied of hardware part of your production (TT Black Element). By now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×