Sign in to follow this  
Followers 0
K2Core

Saphira - Scroll wiggle in some positions

21 posts in this topic

I bought my Saphira 3 months ago. It's really greate mouse with epic sensor and switches, but i have one problem. In some positions scroll feels loose. It's not totally loose, it's like half milimetr space that scroll can move to left and up, so in fast movement it wiggle, do some noise and you can acutally feel it when you move mouse mid-air. On other steps scroll is rock solid and you don't feel any loose on it when move mid air. The steps don't change it always wiggle on certain spots, so i can scroll forward 3 steps from good position, it will go wiggle, and then go back 3 steps and it stops doing it.

 

I think it's not enough to send it on guarantee, but is there any tip how to make it less distracting?

And is it sign of future scroll problems like in some first faulty saphiras or is it normal and I just should get used to it?

 

Video about the problem:

 

 

Sorry for englisherino ;]

 

eqeqeqe, HowardAbuh and Rolandkatt like this

Share this post


Link to post
Share on other sites

I bought my Saphira 3 months ago. It's really greate mouse with epic sensor and switches, but i have one problem. In some positions scroll feels loose. It's not totally loose, it's like half milimetr space that scroll can move to left and up, so in fast movement it wiggle, do some noise and you can acutally feel it when you move mouse mid-air. On other steps scroll is rock solid and you don't feel any loose on it when move mid air. The steps don't change it always wiggle on certain spots, so i can scroll forward 3 steps from good position, it will go wiggle, and then go back 3 steps and it stops doing it.

 

I think it's not enough to send it on guarantee, but is there any tip how to make it less distracting?

And is it sign of future scroll problems like in some first faulty saphiras or is it normal and I just should get used to it?

 

Video about the problem:

 

 

Sorry for englisherino ;]

Hey K2Core, I've tried with one of the Saphira here and it worked perfectly without and wiggling!

Which country are you located? We'll have our local office to assist you for the issue for Saphira! ;)

K2Core likes this

Share this post


Link to post
Share on other sites

Yo Josh! The Hero of Thermaltake Mankind! I'm located in east side Poland, Comrade!

Yo K2Core, please contact our Customer Support at cs2@thermaltake.com.tw, we will have our Customer Representative to help you out with the Saphira!

 

Keep me updated with your issue too! ;)

Share this post


Link to post
Share on other sites

Josh! The sh*t is happening! 

Delivery to the following recipient failed permanently:

     cs2@thermaltake.com.tw

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain thermaltake.com.tw by spam.thermaltake.com.tw. [59.124.46.78].

The error that the other server returned was:
500 5.0.0 Service unavailable

Tried 3 times changing the text but it doesn't help ;<

JOSH HELP!

Share this post


Link to post
Share on other sites

#### it,Josh, this wiggle is going crazy now, only 1 step is not wiggling and wiggle is hard, so you can acutally hear it when you play. How much time it takes for support to answer?

Share this post


Link to post
Share on other sites

Aaaaaaaaaaand it's happening ;< Mouse starts to don't give a #### about my 1tap skill and it likes to thinkt hat i keep my mouse button pressed longer that i'm [it's not physically blocking, it's something wrong with mouse hardware] i 1tap and it sometimes 1tap and sometimes keep it for something like 3 bullets ;<

Share this post


Link to post
Share on other sites

Hey K2Core, sorry for the late reply, as our customer support closes during weekend, therefore, they might not be able to reply you during that period. 

 

If you're still not getting any reply from them, please inform me! ;)

Share this post


Link to post
Share on other sites

Inbox is stil empty ;< But now i'm dealing with the shop where i bought the mice for swapping it to new one, becuase let's face the true. This one is pretty irreparable, the only thing that's working there is sensor. Buttons are lagging / freezing sometimes, scroll is wiggling, left side pad were glued in bad position, so glue lifespan got really shorten. It's scarry what else can go wrong ;) I would like my shop to swap it for the new Saphira, take mine and then they would cover warranty themselves, becuase c'mon i bought this mice 3 months ago, and week ago i bought bigger mousepad for it, it would be really sad to stay now for something like month without a mice!

Share this post


Link to post
Share on other sites

Inbox is stil empty ;< But now i'm dealing with the shop where i bought the mice for swapping it to new one, becuase let's face the true. This one is pretty irreparable, the only thing that's working there is sensor. Buttons are lagging / freezing sometimes, scroll is wiggling, left side pad were glued in bad position, so glue lifespan got really shorten. It's scarry what else can go wrong ;) I would like my shop to swap it for the new Saphira, take mine and then they would cover warranty themselves, becuase c'mon i bought this mice 3 months ago, and week ago i bought bigger mousepad for it, it would be really sad to stay now for something like month without a mice!

Hey K2Core, I've checked with the Customer Support. The issue has already been escalated to our Europe office and there will be someone to address you as soon as possible!

 

Keep me updated for your issue!  ;)

Share this post


Link to post
Share on other sites

Yo Josh! The shop is staying silent so i think i will send it to you [i have receipt etc.] in next month. I have only one more question. In almost every photo in intenet saphira have 2 large  sliders under the mouse and mine have 4 smaller one. Is it normal?

Share this post


Link to post
Share on other sites

Yo Josh! The shop is staying silent so i think i will send it to you [i have receipt etc.] in next month. I have only one more question. In almost every photo in intenet saphira have 2 large  sliders under the mouse and mine have 4 smaller one. Is it normal?

Hey K2Core, please PM me with your receipt when you get it ;) 

 

As for the sliders, can you take a photo for it? I will need to check that for you ;)

Share this post


Link to post
Share on other sites

Hey Josh! I checked how much it will cost me to send the mouse to eu support that i were directed to and #### it. It's Something like 50-60zł, where the mouse price is 130zł. Sending it to you for the warranty is 40-50% of mouse cost, so it's really unprofitable now for me ;<

Share this post


Link to post
Share on other sites

Hey Josh! I checked how much it will cost me to send the mouse to eu support that i were directed to and #### it. It's Something like 50-60zł, where the mouse price is 130zł. Sending it to you for the warranty is 40-50% of mouse cost, so it's really unprofitable now for me ;<

Hey K2Core, did you receive reply from our Europe office regarding on the price for returning the product to us? Please send me a PM with the reply from our Europe office, I'll check it for you ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0