Tt Alvin

Water 3.0 Ultimate -- 360mm radiator

31 posts in this topic

Our new All-in-one water cooling solution with an especially large 360mm radiator design, just one simple upgrade allows you to enjoy a better cooling performance.

 

Webpage

http://www.thermaltake.com/Cooling/Liquid_Cooler_/All_in_One/C_00002345/Water_3_0_Ultimate/Design.htm

 

main.jpg

 

 

pic3.jpg

 

pic5.jpg

 

 

Check out the video

 

 

Water Block Material : Copper

Pump Motor speed : 3600+-150 RPM
Rated Voltage : 12V

Fan Dimension : 120 x 120 x 25mm
Speed : 1000~2000RPM
Noise Level : 20 dBA
Rated Voltage : 12V
Max. Air Flow : 99 CFM
Connector : 4 Pin

Radiator Dimension : 393x 120 x 27 mm
Material : Aluminum

Tube Length : 326 mm
Material : Rubber

Weight 1.32 kg

 

Compatibility

Intel
LGA 2011
LGA 1366
Core i7
LGA 1150/1155/1156
Core i7/Core i5/Corei3

AMD
FM2 / FM1
A-series
AM3+ / AM3
Phenom II/Athlon II/Athlon/Sempron series
AM2+ / AM2 
Phenom II/Phenom/Athlon/Sempron series

RVFER, JaHlo, HuGo_0 and 2 others like this

Share this post


Link to post
Share on other sites

I have a question maybe one of you guys can help with. im using a Thermaltake water 3.0 ultimate on a ASUS CROSSHAIR V FORMULA-Z motherboard. im in 2 minds because that board comes with a really solid steel backplate. so my question is, do i need to use the plastic plate that comes with the 3.0 ultimate or could i just use the stock one from the board?

Share this post


Link to post
Share on other sites

Hi all i am interested in the 3.0 Ultimate but i was wondering, can it be installed into the Core V71 with the 2x200mm on the top  of the case if not are the tubes long enough to put it on the front of the case?

 

thanks

Share this post


Link to post
Share on other sites

Hey guys,

 

Does anyone know the screw thread size for the Water 3.0 Ultimate radiator? I'm installing a shroud between the fans in a pull configuration and need longer screws, but I'm don't know what thread size to get.

 

Thanks

Share this post


Link to post
Share on other sites

Hello everyone!  This is probably a real dumb question though.  I recently installed a 360 cooler and I don't think the pump is running at full speed!  In the BIOS and HWMonitor, the rpm's shown is only 1800 for the pump.  I have tried connecting to CPU_Fan and CPU_OPT headers without avail, same thing.  My MOBI is ASUS X99 Deluxe.  I was under the impression the pump was supposed to be working around the 3000 rpm range.  Do I need to go straight to the power supply from the pump 3 pin header?  I'm at a loss as this is the first AIO cooler ever installed.  Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

Hello everyone!  This is probably a real dumb question though.  I recently installed a 360 cooler and I don't think the pump is running at full speed!  In the BIOS and HWMonitor, the rpm's shown is only 1800 for the pump.  I have tried connecting to CPU_Fan and CPU_OPT headers without avail, same thing.  My MOBI is ASUS X99 Deluxe.  I was under the impression the pump was supposed to be working around the 3000 rpm range.  Do I need to go straight to the power supply from the pump 3 pin header?  I'm at a loss as this is the first AIO cooler ever installed.  Any help would be greatly appreciated.

hi sir, 

 

its the pump connector at 3pin? if yes i could say its running at max speed.

i think 1800 is about right, and if its 3pin your hardware monitoring wont detect it correctly.

 

im also using a 240mm aio. the pump connector is also 3pin and its running max rpm. monitoring shows 2400rpm. but i know its not accurate.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now