Jump to content
mxYELLOW

Saphira mouse freezes and scroll wheel issuesa. Please help.

Recommended Posts

Hello guys.

 

My mom bought me the Saphira mouse from abroad as a present. The device works perfectly but after 2 months it shows some issues. The mouse dies/freezes for a few seconds (about 4-5 seconds). I say that it dies because the DPI and lightings turns off then on again except for the sensor at the bottom. This issue started as random but now it occurs frequently. The scroll wheel also jumps down for some odd reason whenever I'm scrolling up (down-scrolling is fine).

 

I really hope you can help me with this as this is my first gaming mouse. Thanks.

Share this post


Link to post
Share on other sites

Hello guys.

 

My mom bought me the Saphira mouse from abroad as a present. The device works perfectly but after 2 months it shows some issues. The mouse dies/freezes for a few seconds (about 4-5 seconds). I say that it dies because the DPI and lightings turns off then on again except for the sensor at the bottom. This issue started as random but now it occurs frequently. The scroll wheel also jumps down for some odd reason whenever I'm scrolling up (down-scrolling is fine).

 

I really hope you can help me with this as this is my first gaming mouse. Thanks.

Hi MXYELLO, Could you please advise where do you live then we can have our distribution to help. Thank you

Share this post


Link to post
Share on other sites

Just a quick update.

 

It seems that my system is automatically turning off the power to a USB Root Hub (I'm hearing the Windows USB plug-in sound). What I've done is I uninstalled the HID compliant mouse on the Device Manager then made a restart. Then from the Universal Serial Bus controllers on Device Manager, I turned off the "Allow the computer to turn off this device to save power" on USB Root Hub's properties. I only turned off the first one on the list. I have seven hubs.

 

Right now the issue seems to be gone.

 

Only the scroll-wheel issue is left now. Any help will be greatly appreciated, thanks.

 

 

Update 2:

I think I found out why the USB hubs are messing around (at least in my case). I have a USB gaming headset and after plugging in a different headphone which uses a headphone jack the problem reoccur. I've disconnected the jack the the issue is gone.

 

Update 3:

The issue is back again. This is really frustrating. :(

Share this post


Link to post
Share on other sites

Just a quick update.

 

It seems that my system is automatically turning off the power to a USB Root Hub (I'm hearing the Windows USB plug-in sound). What I've done is I uninstalled the HID compliant mouse on the Device Manager then made a restart. Then from the Universal Serial Bus controllers on Device Manager, I turned off the "Allow the computer to turn off this device to save power" on USB Root Hub's properties. I only turned off the first one on the list. I have seven hubs.

 

Right now the issue seems to be gone.

 

Only the scroll-wheel issue is left now. Any help will be greatly appreciated, thanks.

 

 

Update 2:

I think I found out why the USB hubs are messing around (at least in my case). I have a USB gaming headset and after plugging in a different headphone which uses a headphone jack the problem reoccur. I've disconnected the jack the the issue is gone.

 

Update 3:

The issue is back again. This is really frustrating. :(

Dear Sir,

Please advise your complete address and the serial number of the mouse. We need to check if this mouse is still in warranty.

Share this post


Link to post
Share on other sites
Guest Tt Josh   
Guest Tt Josh

Hey mxYELLOW, kindly provide the information required to Frank via private message, they will assist you further on the issue! ;)

Share this post


Link to post
Share on other sites

I got the package. Awesome.

I noticed that this one has a coarse pattern on both sides which gives it a better feel and makes it way better to lift. Kudos!

 

It's the one on the right. 

TFRcSpd.jpg

 

9ZIzinP.jpg

Share this post


Link to post
Share on other sites

Dear, We would send you a new one this week.

I have the same problem. S/N MO-SPH008DT1202004795. Bought on amazon.es on Dec'13. Contacted with thermaltake.de and the offer to repair BUT I have to pay for the shipping, which is more than half the prize of the mouse  :(.  Amazon offers a refund but I love this mouse (when the scroll wheel doesn't get crazy).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×