Jump to content
abc617

Theron Mouse Software - Warning Please plug-in Gaming Device...

Recommended Posts

Hi, I have a Theron Plus Smart Mouse and I installed the TheronPlus Software and everytime I try to run the program now, I get the following error message: 

 

Warning Please plug-in Gaming Device to start the AP configuration!

keKV8fs.png

 

It was working the first time I installed the program. But then I had problems messing with the macros and had to re-install the program. Now this error message pops up whenever I attempt to run the Theron Plus software.

 

I tried uninstalling the software, drivers, restarting, registry cleaning in all sorts of combinations, but none of whatever I tried have seemed to work. 

 

Any help would be appreciated, thanks!

 

Any help in resolving this issue would be appreciated! Thanks.

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi, I have a Theron Plus Smart Mouse and I installed the TheronPlus Software and everytime I try to run the program now, I get the following error message: 

 

Warning Please plug-in Gaming Device to start the AP configuration!

keKV8fs.png

 

It was working the first time I installed the program. But then I had problems messing with the macros and had to re-install the program. Now this error message pops up whenever I attempt to run the Theron Plus software.

 

I tried uninstalling the software, drivers, restarting, registry cleaning in all sorts of combinations, but none of whatever I tried have seemed to work. 

 

Any help would be appreciated, thanks!

 

Any help in resolving this issue would be appreciated! Thanks.

Hi abc617, did you try to plug it into another USB port?

 

Keep me updated! ;)

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi, I have a Theron Plus Smart Mouse and I installed the TheronPlus Software and everytime I try to run the program now, I get the following error message: 

 

Warning Please plug-in Gaming Device to start the AP configuration!

keKV8fs.png

 

It was working the first time I installed the program. But then I had problems messing with the macros and had to re-install the program. Now this error message pops up whenever I attempt to run the Theron Plus software.

 

I tried uninstalling the software, drivers, restarting, registry cleaning in all sorts of combinations, but none of whatever I tried have seemed to work. 

 

Any help would be appreciated, thanks!

 

Any help in resolving this issue would be appreciated! Thanks.

Hey abc617,

 

Try to install this SOFTWARE, click HERE.

 

Once you've installed, launched the program and click RECOVERY.

 

Hope this helps!

 

Keep me updated! ;)

Share this post


Link to post
Share on other sites

Hey abc617,

 

Try to install this SOFTWARE, click HERE.

 

Once you've installed, launched the program and click RECOVERY.

 

Hope this helps!

 

Keep me updated! ;)

 

Thanks Josh, that program fixed my issue completely. I did try plugging into a different USB port, that didn't fix it, but the program sure did. Was that program available anywhere else because I sure couldn't find it. Thanks.

Share this post


Link to post
Share on other sites
Guest Tt Josh

Thanks Josh, that program fixed my issue completely. I did try plugging into a different USB port, that didn't fix it, but the program sure did. Was that program available anywhere else because I sure couldn't find it. Thanks.

That was an updated version, it will be uploaded to our official website soon! ;)

Share this post


Link to post
Share on other sites
Guest Tt Josh

Just checked with the product management team and they are currently doing an upgrade for the theron software.

Share this post


Link to post
Share on other sites
Guest Tt Josh

i have the same problem even using another computer X_x any solution for this?

Hi, can you please install the file below and take a screenshot of what being showed? We will need to know more information on this.

 

Click HERE to download

Share this post


Link to post
Share on other sites

kindly find below screenshot for reference... :D

WeQUhDk.png

 

the other software doesn't even run when i click on recovery. it's stop working. i tried also "run as administrator" but no luck.

this happened after configuring the buttons and the led settings. meaning i was able to use the software first time. XD

Share this post


Link to post
Share on other sites
Guest Tt Josh

kindly find below screenshot for reference... :D

WeQUhDk.png

 

the other software doesn't even run when i click on recovery. it's stop working. i tried also "run as administrator" but no luck.

this happened after configuring the buttons and the led settings. meaning i was able to use the software first time. XD

We'll look into this and will get back to you once we have the solution.

Share this post


Link to post
Share on other sites

I've also had a problem with this mouse. It is a theron mouse and it says warning connect gaming device when it is already connected like the others. But the recovery thing keeps crashing.

Pls Help. also it says my mouse is hid complaint mouse, is that suppose to be like that?

Share this post


Link to post
Share on other sites

Okay I did that but is there supposed to be something that pops up when i double click the command center application, because it isn't doing anything, at least that i know of

Share this post


Link to post
Share on other sites
Guest Tt Josh

Okay I did that but is there supposed to be something that pops up when i double click the command center application, because it isn't doing anything, at least that i know of

Did you restart you computer? and which operating system are you using?

Share this post


Link to post
Share on other sites

Hello,

 

I'm on windows 10 too and i have same probleme : "please plug-in gaming device to start the ap configuration"

 

So i tried TT ESPORTS COMMAND CENTER V1.02

 

But i can't open the software, double clic does nothing. I can only right clic on the icone.

 

we did the same. i uninstalled it since nothing is happening. only showing the same image but in english.

Share this post


Link to post
Share on other sites

Hello i found the solution,

 

i uninstalled all theron software. (Macro/bind still working, i don't know if it's normal)

 

I installed as ADMINISTRATOR : http://www.ttesports..._tool150331.zip

The software told me "not need update firmware"

 

Then i installed on my windows 10 as ADMINISTRATOR : TT ESPORTS COMMAND CENTER V1.02

Installtion ok but i can't access to configuration of mouse.

 

 

Go to Theron install folder and enable ADMINISTRATOR mode for the two executable files.

 

Launch Tt eSPORTS Command Center.exe as admin. It will download last firmware for mouse and then it works !

 

post-102376-0-82998300-1466587894_thumb.png

Share this post


Link to post
Share on other sites

This is so garbage software and drivers just fix a mouse. Wow never had an issue with razor. No wonder this mouse was $40 off its basically a piece of **** and stopped working the first day. I will literally return this garbage tomorrow.

Share this post


Link to post
Share on other sites

This is so garbage software and drivers just fix a mouse. Wow never had an issue with razor. No wonder this mouse was $40 off its basically a piece of **** and stopped working the first day. I will literally return this garbage tomorrow.

 

then concider yourself lucky i had several annoying issues with my razor blackwidow ultimate over the years

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×