RealNeo

BlackV2 not working on Windows 8.1 (64bit)

3 posts in this topic

Dear Community,

 

I recently bought a TT eSports Black V2 mouse, I downloaded the GUI software from main website and tried installing the software (This step works), In my taskbar I can see the "Black V2 Monitor" however double clicking it doesn't do anything, (I think it should fire up BlackV2.exe). So I tried starting BlackV2.exe and it still doesn't do anything, tried running it in different compability mode's and still no kick.

 

The mouse works great however its just that the GUI doesn't work. I tried installing the GUI for SmartMouse and this one opened and said 'Please plug in the device' or something similair.

 

Does anybody else experience same issues on Windows 8.1 x64?

 

Also I noticed that in Windows Event viewer it logs an Application Crash for BlackV2.exe (However no data that said specifically whats wrong).

 

If that information could be helpful for anybody solving the problem than I would be glad to give it.

 

Thanks in advance!, Real Neo

Richardsaky likes this

Share this post


Link to post
Share on other sites

Try to reinstall and restart your computer. You can try to plug it in to another USB and check whether same issue occurs. :)

Share this post


Link to post
Share on other sites

I have the same issue but in my case windows7 ultimate 64bit.

So it does not matter which OS.

Try enter into bios of pc. you will see mouse not response too.

May be something in bios to do

As I am thinking more it is not depends on os at all.

may be some checkbox in the bios (I mean new modern bios)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now