Jump to content

Welcome to Tt Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

Note:
If you are experiencing technical difficulties with your registration process, or if you have not received a confirmation mail, please drop an e-mail to ttcommunity@thermaltake.com with your registered username/e-mail. We will sort out your request as soon as possible, sorry for any inconvenience

Photo

**ATTN Users with Thermaltake Riser Cables**

- - - - - Core P5 Riser Cable PCIE

  • Please log in to reply
238 replies to this topic

#1
ThermalMike

ThermalMike

    Senior Member

  • Moderators
  • 505 posts
  • LocationCalifornia, USA

**ATTN Users with Thermaltake Riser Cables**

**UPDATED 8/3/2016**

If you are experiencing issues with your Thermaltake Riser Cable product, please help to contact our support for warranty replacement options.

Email Contacts:

USA/Canada/South America:
ttsupport@thermaltakeusa.com

International Global Customers:
info@thermaltake.com

Subject: Thermaltake Riser Cable Request

What we need:
1. Motherboard Make/Model
2. GPU Make/Model
3. Your invoice/receipt
4. Brief description on the issues you are having
5. Your shipping address
6. Your Name
7. Phone Number (For shipping purposes)

Once your email has been received, please allow 1-3 business days for processing.
Due to region availability, some requests may be delayed.

 


  • HaroldOn, robert and Moviemakergr like this

Mike Fierheller

Thermaltake USA - Product Manager

Email:   mike.fierheller@thermaltakeusa.com

test.jpg

 

Project SunkisTt:

Core V71 (Candy Painted & Chromed) ≡ EVGA Z87 Classified ≡ 4790K @4.6ghz ≡ 2x ZOTAC GTX 980 Ti's with Pacific V-GTX 980Ti Transparent Water Block
2x Pacific RL280 Radiators (Polished)  ≡ Pacific PR22-D5 Res+Pump Pacific W2 ≡ 2x Samsung Evo 256GB -RAID 0 ≡ Tt Toughpower  DPS G 1200W

 

------------------------------------------------------------

Thermaltake USA Customer Service

Email: ttsupport@thermaltakeusa.com

Toll Free: 1-800-988-1088 M-F 9:00AM~5:30PM (P.S.T)

 

 

 


#2
_ThE_PsYcHoTiK_

_ThE_PsYcHoTiK_

    Beginner

  • Members
  • Pip
  • 7 posts

Thanks for that, but I return the riser last week and it's cost me 9€ ...

 

Did you get a refund, or a free riser for a crossfire when you return the replacement?

 

Because I haven't got any news for buying a second cable for my crossfire...

 

sorry for my very bad English



#3
ThermalMike

ThermalMike

    Senior Member

  • Moderators
  • 505 posts
  • LocationCalifornia, USA

Thanks for that, but I return the riser last week and it's cost me 9€ ...

 

Did you get a refund, or a free riser for a crossfire when you return the replacement?

 

Because I haven't got any news for buying a second cable for my crossfire...

 

sorry for my very bad English

Hello,

 

Thanks for letting me know and sending me an email. I will get in contact with our team in your region and see what we can do.


Mike Fierheller

Thermaltake USA - Product Manager

Email:   mike.fierheller@thermaltakeusa.com

test.jpg

 

Project SunkisTt:

Core V71 (Candy Painted & Chromed) ≡ EVGA Z87 Classified ≡ 4790K @4.6ghz ≡ 2x ZOTAC GTX 980 Ti's with Pacific V-GTX 980Ti Transparent Water Block
2x Pacific RL280 Radiators (Polished)  ≡ Pacific PR22-D5 Res+Pump Pacific W2 ≡ 2x Samsung Evo 256GB -RAID 0 ≡ Tt Toughpower  DPS G 1200W

 

------------------------------------------------------------

Thermaltake USA Customer Service

Email: ttsupport@thermaltakeusa.com

Toll Free: 1-800-988-1088 M-F 9:00AM~5:30PM (P.S.T)

 

 

 


#4
baonguyen84

baonguyen84

    Beginner

  • Members
  • Pip
  • 1 posts

Sent you an email last night about my current cable that I have. It doesn't work in my 16x slot but it does with my 8x slot. The thing is that when it's in my 8x slot it keep putting my monitor to sleep mode every 15 sec when I'm gaming.  



#5
Jakevsnake

Jakevsnake

    Just Getting Started

  • Members
  • PipPip
  • 16 posts
Just submitted an email. Really hope there is a new cable that will fix this issue. MountIng the GPU using th riser card was the main reason I bought this.

#6
Moviemakergr

Moviemakergr

    Just Getting Started

  • Members
  • PipPip
  • 11 posts

We have a new about replacement ?

 

Nobody has received the new ?



#7
Jakevsnake

Jakevsnake

    Just Getting Started

  • Members
  • PipPip
  • 16 posts
I would also love to hear anyone's experience with the new cable.

#8
Moviemakergr

Moviemakergr

    Just Getting Started

  • Members
  • PipPip
  • 11 posts

I received the new cable and all seem to operate normally, thanks Thermaltake for direct support. !



#9
Jakevsnake

Jakevsnake

    Just Getting Started

  • Members
  • PipPip
  • 16 posts

I received the new cable and all seem to operate normally, thanks Thermaltake for direct support. !

Did you get any confirmation via email that they were shipping you a cable?  I emailed Mike and I have not seen a reply in email or this forum.  It would be nice to know if they received my request and be told when i can expect a replacement.



#10
Moviemakergr

Moviemakergr

    Just Getting Started

  • Members
  • PipPip
  • 11 posts

Yes I had information that will be sent to me.

It came very quickly europe that is me with fedex 3 days from china.



#11
Jakevsnake

Jakevsnake

    Just Getting Started

  • Members
  • PipPip
  • 16 posts

Unfortunately for me I have received no response via email or PM going on for over a week now.



#12
Moviemakergr

Moviemakergr

    Just Getting Started

  • Members
  • PipPip
  • 11 posts

Send here a mail <> cs2@thermaltake.com



#13
realrattus

realrattus

    Beginner

  • Members
  • Pip
  • 7 posts
Faulty cable as well...email sent March 3.

#14
ThermalMike

ThermalMike

    Senior Member

  • Moderators
  • 505 posts
  • LocationCalifornia, USA

Hey everyone,

 

Sorry for any delays on the requests.

 

I was traveling out of the country last week and I am going through all the details.

 

We are waiting on more cables to be delivered, once I have them we will contact everyone for the shipments.

 

Hang in there, will have them soon.


Mike Fierheller

Thermaltake USA - Product Manager

Email:   mike.fierheller@thermaltakeusa.com

test.jpg

 

Project SunkisTt:

Core V71 (Candy Painted & Chromed) ≡ EVGA Z87 Classified ≡ 4790K @4.6ghz ≡ 2x ZOTAC GTX 980 Ti's with Pacific V-GTX 980Ti Transparent Water Block
2x Pacific RL280 Radiators (Polished)  ≡ Pacific PR22-D5 Res+Pump Pacific W2 ≡ 2x Samsung Evo 256GB -RAID 0 ≡ Tt Toughpower  DPS G 1200W

 

------------------------------------------------------------

Thermaltake USA Customer Service

Email: ttsupport@thermaltakeusa.com

Toll Free: 1-800-988-1088 M-F 9:00AM~5:30PM (P.S.T)

 

 

 


#15
Gremory830

Gremory830

    Beginner

  • Members
  • Pip
  • 7 posts

Faulty cable as well...email sent March 3.

I got my new cable about two weeks ago and I'm already having the same issue!!! #### it takes hours to drain and pull my loop off to change these cables out. Yall really #### up on this. 



#16
Jakevsnake

Jakevsnake

    Just Getting Started

  • Members
  • PipPip
  • 16 posts

I got my new cable about two weeks ago and I'm already having the same issue!!! #### it takes hours to drain and pull my loop off to change these cables out. Yall really #### up on this. 

That is disappointing to hear.  I would like to know what Thermaltake is doing to ensure the new cables are meeting design requirements?  Being able to showcase my GPU with this case was a primary factor in my decision to purchase.  If I have to mount directly to my motherboard in order to have reliable performance from my GPU then this is a huge failure on the part of Thermaltake. 

 

Does anyone know where we may be able to get a cable to meet our needs outside the Thermaltake supply chain?  I just need this to get fixed and move on.



#17
realrattus

realrattus

    Beginner

  • Members
  • Pip
  • 7 posts

Newegg has these for 5 bucks....just an FYI if your still waiting. ####, I havent even receieved a freaking response that my email was received. Not a great impression for my first thermaltake product.



#18
ThermalMike

ThermalMike

    Senior Member

  • Moderators
  • 505 posts
  • LocationCalifornia, USA

Hello everyone,

 

If you emailed me I have your information.

 

I am waiting on the next shipment of cables to be delivered to send out, sorry for any delay.

 

I have seen great results with 99% of the cables we shipped out.

 

If you are still having issues after receiving the new cable, please contact me via email with some details so we can review.


Mike Fierheller

Thermaltake USA - Product Manager

Email:   mike.fierheller@thermaltakeusa.com

test.jpg

 

Project SunkisTt:

Core V71 (Candy Painted & Chromed) ≡ EVGA Z87 Classified ≡ 4790K @4.6ghz ≡ 2x ZOTAC GTX 980 Ti's with Pacific V-GTX 980Ti Transparent Water Block
2x Pacific RL280 Radiators (Polished)  ≡ Pacific PR22-D5 Res+Pump Pacific W2 ≡ 2x Samsung Evo 256GB -RAID 0 ≡ Tt Toughpower  DPS G 1200W

 

------------------------------------------------------------

Thermaltake USA Customer Service

Email: ttsupport@thermaltakeusa.com

Toll Free: 1-800-988-1088 M-F 9:00AM~5:30PM (P.S.T)

 

 

 


#19
ThermalMike

ThermalMike

    Senior Member

  • Moderators
  • 505 posts
  • LocationCalifornia, USA

I got my new cable about two weeks ago and I'm already having the same issue!!! #### it takes hours to drain and pull my loop off to change these cables out. Yall really #### up on this. 

 

Sorry I cannot check who you are on my email with this if you already sent.

 

The cable could have had an issue, but hard to say with 2 bad cables.

 

I can send you another cable to check if the new one was DOA, let me know.


Mike Fierheller

Thermaltake USA - Product Manager

Email:   mike.fierheller@thermaltakeusa.com

test.jpg

 

Project SunkisTt:

Core V71 (Candy Painted & Chromed) ≡ EVGA Z87 Classified ≡ 4790K @4.6ghz ≡ 2x ZOTAC GTX 980 Ti's with Pacific V-GTX 980Ti Transparent Water Block
2x Pacific RL280 Radiators (Polished)  ≡ Pacific PR22-D5 Res+Pump Pacific W2 ≡ 2x Samsung Evo 256GB -RAID 0 ≡ Tt Toughpower  DPS G 1200W

 

------------------------------------------------------------

Thermaltake USA Customer Service

Email: ttsupport@thermaltakeusa.com

Toll Free: 1-800-988-1088 M-F 9:00AM~5:30PM (P.S.T)

 

 

 


#20
Gremory830

Gremory830

    Beginner

  • Members
  • Pip
  • 7 posts

Sorry I cannot check who you are on my email with this if you already sent.

 

The cable could have had an issue, but hard to say with 2 bad cables.

 

I can send you another cable to check if the new one was DOA, let me know.

Hey Mike. Sorry just seeing this reply now. Yall already sent me one cable. I have e-mailed you from my gmail again about the second cable being dead you asked me what video card I had. I replied and have not herd anything back for a few days. It seems the cable will work for a few hours if I turn the pc off and wiggle the base of the cable near the video card itself. It's weird because it was working great and just one day the issues started again.  I have moved my card or cable before the issue came back as I have a custom loop on the cpu and gpu.... kinda makes it a long ordeal just to move anything. 







Also tagged with one or more of these keywords: Core P5, Riser Cable, PCIE

3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users