Jump to content
ThermalMike

**ATTN Users with Thermaltake Riser Cables**

Recommended Posts

Just throwing my hat into the ring with this problem.  Just bought a Core P5 it has the white clip on the riser cable and my video card (Asus Poseidon 1080ti) on MB(Asus ROG maximus Hero X AC wifi w/ i7-8700k) and when I check the video card with GPU-Z it is showing that it is only able to come up at x8 1.1.  I am sure it is in the correct PCIe slot and the BIOS even if I force it to x16 gen3 I still only get x8.  

Funny how you know there is a major problem when you run a benchmark on the video and the result was WAY under my 1060 GTX card, and barely better than a built in laptop graphics card lol.  

I sent in the email yesterday as per Mike, so I will have to hurry up and wait.  

Not to be "that guy" but if this has been going on since Feb 2016 why are these white clip cables still being shipped with newer stock?  

Share this post


Link to post
Share on other sites
7 hours ago, blackice said:

Just throwing my hat into the ring with this problem.  Just bought a Core P5 it has the white clip on the riser cable and my video card (Asus Poseidon 1080ti) on MB(Asus ROG maximus Hero X AC wifi w/ i7-8700k) and when I check the video card with GPU-Z it is showing that it is only able to come up at x8 1.1.  I am sure it is in the correct PCIe slot and the BIOS even if I force it to x16 gen3 I still only get x8.  

Funny how you know there is a major problem when you run a benchmark on the video and the result was WAY under my 1060 GTX card, and barely better than a built in laptop graphics card lol.  

I sent in the email yesterday as per Mike, so I will have to hurry up and wait.  

Not to be "that guy" but if this has been going on since Feb 2016 why are these white clip cables still being shipped with newer stock?  

Hi Blackice,

Based on your location, I would suggest you just contact us in the USA:

https://thermaltakeusa.zendesk.com/hc/en-us

Since we cover your region, you do not have to go through our global support. Call us today to get a replacement setup.

Make sure you have your proof of purchase :)

Share this post


Link to post
Share on other sites
1 hour ago, ThermalMike said:

Hi Blackice,

Based on your location, I would suggest you just contact us in the USA:

https://thermaltakeusa.zendesk.com/hc/en-us

Since we cover your region, you do not have to go through our global support. Call us today to get a replacement setup.

Make sure you have your proof of purchase :)

Done before I posted on the forums.  I did receive an email today telling me they are shipping out a new cable.  

Share this post


Link to post
Share on other sites
On 12/4/2017 at 10:07 PM, blackice said:

Done before I posted on the forums.  I did receive an email today telling me they are shipping out a new cable.  

Im starting to lose hope in this company,asked for a replacement for my broken riser cable last week,and no reply/email from the support on global.I feel almost cheated, replacing the cable for a TT one is like nearly what i paid for the case.

Share this post


Link to post
Share on other sites
1 hour ago, Booze said:

Im starting to lose hope in this company,asked for a replacement for my broken riser cable last week,and no reply/email from the support on global.I feel almost cheated, replacing the cable for a TT one is like nearly what i paid for the case.

Not sure why, I have an email from TT support that says mine is being shipped out.  I am in Canada though. 

Share this post


Link to post
Share on other sites

So are the cases that are being sold now with the riser cable all with the newer  working  cables? Were all the old cases with the troublesome cables recalled? 

Would be good to know before someone buys a case and getting one of the bad cables. Not having to worry about sending off emails. 

Share this post


Link to post
Share on other sites

Contacted support for Belgium (i guess it's the german support) 6 months ago, they said they would send me a replacement cable. Still nothing received after 6 #### months. I have send 5 #### emails back and they don't even answer, worst support ever!

As you can see I am very #### right now. Never ever will I buy anything from Thermaltake again, now I have to invest another #### 60-80 euros for a decent pci-e extender.

Share this post


Link to post
Share on other sites
On 8/11/2017 at 4:16 PM, ThermalMike said:

You should be fine as long as you include proof of purchase, if you need, just email them again with the info.

Please see the OP for details.

Hope you get the replacement soon.

Hey Mike its me again, i get an email from you telling me "I will be forwarding this over to our team in your region to follow up.
They will support you from here on the replacement cable. Normally they will not reply until replacement has been processed.
Time frame will vary depending on region and availability. "
So that was a month ago and i didnt get any notice or something thats tellme they are taking care.. can u dig up a lil and get some news? (my video card is like hanging literally i need that cable asap! :help: )

Share this post


Link to post
Share on other sites
On 12/10/2017 at 2:12 PM, Swinox said:

Contacted support for Belgium (i guess it's the german support) 6 months ago, they said they would send me a replacement cable. Still nothing received after 6 #### months. I have send 5 #### emails back and they don't even answer, worst support ever!

As you can see I am very #### right now. Never ever will I buy anything from Thermaltake again, now I have to invest another #### 60-80 euros for a decent pci-e extender.

Please list out the email you are using to contact us. Do you have a way to confirm we got it?

Did you try to call us in the 6 months? - help me out here so I can help you too.

http://www.thermaltake.com/corporate.aspx?t=4

Share this post


Link to post
Share on other sites
4 hours ago, MONO85 said:

Hey Mike its me again, i get an email from you telling me "I will be forwarding this over to our team in your region to follow up.
They will support you from here on the replacement cable. Normally they will not reply until replacement has been processed.
Time frame will vary depending on region and availability. "
So that was a month ago and i didnt get any notice or something thats tellme they are taking care.. can u dig up a lil and get some news? (my video card is like hanging literally i need that cable asap! :help: )

Hi Mono85,

Can you email me again so I know its you and I will see what I can do. Sorry for the delays.

Share this post


Link to post
Share on other sites
23 hours ago, ThermalMike said:

Hi Mono85,

Can you email me again so I know its you and I will see what I can do. Sorry for the delays.

LOL, this morning i get the cable, I think is not this one (AC-053-CN1OTN-C1 http://www.thermaltake.com/products-model.aspx?id=C_00003084 ) mine has the circuit board blue, and has a ruber striped flex, with a sticker with the logo on both sides... so i dont know if this is right or not... I am going to test it right now.. so i let u know how it goes.
Thank you!

Share this post


Link to post
Share on other sites
On 2017. 08. 12. at 11:28 PM, iFA88 said:

Greetings!

Have the same trouble like many costumers here.
I have send email on 03.08.2017 to info@thermaltake.com and requested reply, but since then I don't received any answer. In my email have wrote every information what on the first page is requested.

Still waiting for answer!

Best regards:
-iFA

 

4 months elapsed and still no answer even to my email and even to my post.. great!

Share this post


Link to post
Share on other sites

Greetings. I purchased a P3 back in October, and my able did not work from the start so after trying to install my gpu with the extender and failing i gave up and installed it normally. Then i discovered a youtube video about this case and the creator talked about this post in this forum, so i emailed info@thermaltake.com (Romania, EU) also made a ticket on the EU support page. Then nothing for about 7 days, then i got a call from UPS to inform me that i have a package. Thermaltake sent a new riser cable, the 20 cm unbent one, and it finally works great with the gpu mounted with the riser cable. Thank you.1.thumb.jpg.fa1078fac2a8ed786e8007be52d28cac.jpg2.thumb.jpg.d7c958a2cd0f66189daf986530462c57.jpg3.thumb.jpg.7543d4a17101375ee562729b323d230c.jpg4.thumb.jpg.67fbdb7e270125ab8fdd6356fe7135ff.jpg

Share this post


Link to post
Share on other sites
On 12/13/2017 at 4:19 AM, iFA88 said:

4 months elapsed and still no answer even to my email and even to my post.. great!

Hi,

Sorry for any delays with our regional teams. I am from the USA.

Have you tried contacting us more than 1 time in this period? Here is our global contact list:

http://www.thermaltake.com/corporate.aspx?t=4

Call us if you cant get a reply to email or maybe check the link and try contacting our offices in your region.

Share this post


Link to post
Share on other sites

Hello

I have a problem to this RISER of the Thermaltake Core P3 , lot of time i have the black screen and have to restart 2 - 3 times the computer, i'm from France where can i have to go to do a support replacement ?

thanks

Share this post


Link to post
Share on other sites
On 12/17/2017 at 8:37 AM, lanner said:

Hello

I have a problem to this RISER of the Thermaltake Core P3 , lot of time i have the black screen and have to restart 2 - 3 times the computer, i'm from France where can i have to go to do a support replacement ?

thanks

Hello,

Please follow the template on the 1st post and and email it to the international email shown.

Share this post


Link to post
Share on other sites

Hello everyone
User in France

I made the request on December 11, 2017, as described on the first page at these two addresses

  info@thermaltake.com; support@thermaltake.de

I just received it tonight on December 19, 2017

Well done to thermaltake for their professionalism better than the reseller.

I'll remember it next time.

I had this http://fr.thermaltake.com/Chassis/Accessoire_/_/C_00002784/PCI_e_X16_Riser_Cable/design.htm

I receive this http://www.thermaltake.com/products-model.aspx?id=C_00003084

Thermaltake have a green programme for return riser no functionnal ?

Share this post


Link to post
Share on other sites

I bought the Core P5 case and the riser cable was not working. I emailed Tt and they responded via email within three days asking for documentation that I actually purchased the case. Sent it to them. Within 7 days of the first email I now have a new cable. The day prior to it coming in the mail I received a phone call where they told me to expect it the next day. I actually haven't tested the new cable yet as I just got it today and I have been busy but I have to give Tt an A+ for customer support. Im astounded that they got me a new cable this quickly. When they called they just asked that I return the old cable to them after I check the new one. I will do so within the next couple days after I test the new cable. My faith in investing in further Tt products has increased because of the quick response time and support. Thanks. Very happy. 

Also- I am in Thailand right now but used the US email address listed when I sent the original email. 

Share this post


Link to post
Share on other sites
5 hours ago, Teusxx said:

Hi guys, I'm from Italy. I sent an email with all information you want to:

info@thermaltake.com (no reply received)

info@thermaltake.eu (Email does not Exist)

 

What can I do?

 

Thanks.

Hello,

PM me the email address you used to contact us and I will have them check to see if they received and try to help.

Share this post


Link to post
Share on other sites

Found this thread and submitted a RMA request following the provided link.  Had my replacement riser cable within a week.  Appreciate the quick turn around.

Now my rig is finally complete!

CoreP5_01.JPG

I also have my 10G NIC on a riser cable behind the Zotac.  Since it is Gen2, it worked with just a plain ribbon cable.

CoreP5_02.JPG

 

I know, I really should hard tube it up!

Share this post


Link to post
Share on other sites
On 2017. 12. 15. at 8:16 PM, ThermalMike said:

Hi,

Sorry for any delays with our regional teams. I am from the USA.

Have you tried contacting us more than 1 time in this period? Here is our global contact list:

http://www.thermaltake.com/corporate.aspx?t=4

Call us if you cant get a reply to email or maybe check the link and try contacting our offices in your region.

Hi.

I have one time sent an email to info@thermaltake.com . I have send again to info@thermaltake.de and to info@thermaltake.eu .
From the info@thermaltake.eu have received mail server error: 550 Unknown user
I'm from Hungary.

Share this post


Link to post
Share on other sites
1 hour ago, iFA88 said:

Hi.

I have one time sent an email to info@thermaltake.com . I have send again to info@thermaltake.de and to info@thermaltake.eu .
From the info@thermaltake.eu have received mail server error: 550 Unknown user
I'm from Hungary.

I have the same problem.. I’m from Italy and don’t know where I can contact us.. In this case I would like to live in USA :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×