Jump to content
ThermalMike

**ATTN Users with Thermaltake Riser Cables**

Recommended Posts

11 hours ago, iFA88 said:

Hi.

I have one time sent an email to info@thermaltake.com . I have send again to info@thermaltake.de and to info@thermaltake.eu .
From the info@thermaltake.eu have received mail server error: 550 Unknown user
I'm from Hungary.

Hi

im Adam,im the Thermaltake Uk and Ireland Marketing Executive 

the eu support email server has had a lot of issues lately.we will have this fixed by the new year.

in the mean time,you can message me,and I will get your request sorted for you.

Share this post


Link to post
Share on other sites
17 minutes ago, ADAM LCS TT said:

Hi

im Adam,im the Thermaltake Uk and Ireland Marketing Executive 

the eu support email server has had a lot of issues lately.we will have this fixed by the new year.

in the mean time,you can message me,and I will get your request sorted for you.

Dear Adam,

Thank you for your message, please give me a *@thermaltake.??? email address where I can send you my email.

Br.

Share this post


Link to post
Share on other sites
On 12-12-2017 at 2:24 AM, ThermalMike said:

Please list out the email you are using to contact us. Do you have a way to confirm we got it?

Did you try to call us in the 6 months? - help me out here so I can help you too.

http://www.thermaltake.com/corporate.aspx?t=4

I have mailed to the corresponding tech support of my region.

tech@thermaltake.com (filled in the tech support request) then support@thermaltake.de

I got a confirmation that they will send the parts free of charge, so I provided them with my shipping address and then nothing.

As stated in their email, I had to attach previous messages, as I did every single time.

I haven't called though, cause I am not really a caller, more of a texter emailer guy. (cause I don't hear very well, partially deaf, I don't like to be confronted with my handicap).

And then after months of waiting emailed by answering their mail again, and again and again, then mailing support again and got nothing. Just the worst support ever.

Share this post


Link to post
Share on other sites
On 4/10/2016 at 3:43 PM, MiPaul said:

Email Sent,

 

 I have experienced a LOT of frustrations with this....... Thought It was video card, Thought it was Windows 10, I tried all Nvidia drivers, went back to a 760GTX, even rolled back to Windows 8.1 same issue, Finally I mounted cards directly into M/B, and both Cards are working Fine!  So I determined a Defective Riser card......Probably because it was folded 180 degrees when I opened the box for the first Time.

 

Riser20Cable20Issue202_zps3viqtxk3.jpg

Here is my original Post on this................ Now same thing is happening again, Was experience poor video lagging and stuttering while playing BF1, Bf4, and ghost Recon Wildlands when using the Riser Card, wouldn't you know it, as soon as the cable was removed and card placed directly in PCI slot, NO LAG WHAT-SO-EVER!!

 

Please advise of Next Step!

Share this post


Link to post
Share on other sites

Guys, I can’t believe it! 

12/28 my new riser cable arrived without any mail from Tt. Now my pc is booting and works, but after 5 minutes in game still crash. So I decided to wrap the riser with alluminium and now it’s working perfectly. 

My gpu connected directly to Mobo go to 120 FPS, with riser go to 60. But I’m very excited anyway :D

Share this post


Link to post
Share on other sites

Hello everyone!

Does the problem exist with the riser cables in those delivered with Core P3? Because I have purchased one back in September and my system would give 3 beeps (VGA not present) when I was using the Thermaltake cable. At the time, I didn't thought that others but me may have the same problem, so I ordered a new one and it works ok, but it is Gen 2 (Gen 3 where way too expensive) and I fear I may have some performance loss.

Am I eligible for a replacement cable?

Share this post


Link to post
Share on other sites

Hi,

On 1/1/2018 at 7:22 AM, ElexorienGR said:

Hello everyone!

Does the problem exist with the riser cables in those delivered with Core P3? Because I have purchased one back in September and my system would give 3 beeps (VGA not present) when I was using the Thermaltake cable. At the time, I didn't thought that others but me may have the same problem, so I ordered a new one and it works ok, but it is Gen 2 (Gen 3 where way too expensive) and I fear I may have some performance loss.

Am I eligible for a replacement cable?

Hello, if you are the original owner and have a copy of your receipt for the purchase of the P3, then yes you can submit for the free cable.

Please just follow the template :)

Share this post


Link to post
Share on other sites

Hello @ThermalMike

If I live in Thailand, which email should I send my request to? Looking forward to have my issues resolved.

I have the same issues as everyone here. Horrible performance, random shutdown, freezes while loading up Windows 10. 

I burnt in my brand new MSI 1080 Twin Frozr. I was struggling to get my old 760 GTX Windforce to work until I gave up thinking it was faulty. I also had my PSU replaced because I thought it was old. Wasted quite a lot of money already just because of this cable issue. Please help me out here. 

69206.jpg

Share this post


Link to post
Share on other sites
58 minutes ago, ้harnzolo said:

Hello @ThermalMike

If I live in Thailand, which email should I send my request to? Looking forward to have my issues resolved.

I have the same issues as everyone here. Horrible performance, random shutdown, freezes while loading up Windows 10. 

I burnt in my brand new MSI 1080 Twin Frozr. I was struggling to get my old 760 GTX Windforce to work until I gave up thinking it was faulty. I also had my PSU replaced because I thought it was old. Wasted quite a lot of money already just because of this cable issue. Please help me out here.

Send an e-mail at info@thermaltake.com

and write:

Subject: Thermaltake Riser Cable Request

1. Motherboard Make/Model
2. GPU Make/Model
3. Your invoice/receipt
4. Brief description on the issues you are having
5. Your shipping address
6. Your Name
7. Phone Number (For shipping purposes)

Share this post


Link to post
Share on other sites
23 hours ago, Aaronawl said:

Hi,

 

I have emailed info@thermaltake.com on the 4th January 2018 but had no reply regarding a riser cable which came with my Core P5 case. Can anyone here help me?

Email them again, maybe it did not go through. Please dont email 1 time and wait weeks for a response :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×