tyt2lynnin1

Poseidon Z RGB - Chatter, double key strokes on Keyboards

58 posts in this topic

Hello!I have the same problem!

My keybord is just like new but with a.s.d.w.z.x an someone keys have problem!When i click a key have two letters on my screen!And somethimes keys just not responding.Can you help me becouse i don't have money for new

Share this post


Link to post
Share on other sites

Please contact:

Thermaltake USA Inc.

20420 Business Parkway, City of Industry, CA, 91789 USA

email: ttsupport@thermaltakeusa.com

Tel: Toll-Free 800-988-1088

M-F 9:00AM – 5:30PM (P.S.T)

Share this post


Link to post
Share on other sites

Hi, I have the exact same problem with my Poseidon Z keyboard. I am currently residing in Denmark. I have tried contacting Thermaltake three times using the online eRMA tool but i have never received any reply. Can you please advise me on how to proceed with my RMA? Thank you

Share this post


Link to post
Share on other sites
On 2017-6-21 at 5:07 PM, Yetti said:

Hi, I have the exact same problem with my Poseidon Z keyboard. I am currently residing in Denmark. I have tried contacting Thermaltake three times using the online eRMAtoolbuti have never received any reply. Can you please advise me on how to proceed with my RMA? Thank you

Could you please contact our German branch directly: 

Thermaltake Germany GmbH

Oststrasse 26, 22844 Norderstedt, Germany
TEL : +49(0)40/30-85-86-0
FAX : +49(0)40/30-85-86-89
E-MAIL :
info@thermaltake.de
support@thermaltake.de 

Yetti likes this

Share this post


Link to post
Share on other sites

I'm currently having an issue with mine. After a while, I started noticing that I was getting double keystrokes. I recently updated the firmware from version 40 to version 51, as well as updating the software to 2.1.2. Now when I experience duplicate keystrokes, it's 3 at a time instead of just 2. I have noticed that in the Windows Device Manager, my Poseidon Z RGB is showing up as 3 'HID Keyboard Device' devices under the Keyboard category. I've tried uninstalling all HID Keyboard Device listings, and unplugging and plugging the keyboard back in, and all 3 listings come back. I would like to fix this soon, or I might have to find a new keyboard. I'm based in Oregon, USA.

Share this post


Link to post
Share on other sites

Hi Robert,

Please contact our USA customer service here:

Thermaltake USA Inc.

20420 Business Parkway, City of Industry, CA, 91789 USA

email: ttsupport@thermaltakeusa.com

Tel: Toll-Free 800-988-1088

M-F 9:00AM to 5:30PM (P.S.T)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now