Nagamasti

Black Gaming Mouse Cursor

3 posts in this topic

I have had my Black Gaming Mouse for some time now (P/N MO-BLK002DT), and have quite often experienced the cursor not working on computer start-up. Usually this is solved by switching the sensitivity up and back down - however it usually doesn't register the first button click.

 

Recently the mouse cursor movement stopped altogether. As per many of the forum posts, the left, right and scroll wheel buttons still work, the mouse lights up correctly, and the sensitivity settings also work, but no tracking of movement.

 

I have tried different USB ports, confirmed the ports are all working with different mouses / keyboards and even USB sticks.

 

I have also installed the Command Center and update tool, but encounter the "Plug in device" screen and cannot proceed.

 

All suggestions I have found from these forums I have followed, but with no success, and the only other response I have seen is to contact customer support.

 

Is there a resolution for this issue, or is contacting customer support the only option for this issue? I am in Adelaide, Australia, so if the appropriate contact details are available, that would be great. If more information is needed, please let me know and I can provide.

 

It would be great if a follow-up of this issue can be posted, whether that is that the mouse is broken and needs to be returned / replaced, that there is a solution, or the that the issue needs to be looked at outside of these forums.

 

This issue aside, I really think both the mouse and gaming keyboards are great, but some it looks like this is a common issue, and a [sOLVED] type post would be awesome.

 

Cheers

Share this post


Link to post
Share on other sites

Hi Nagamsti,

 

Very sorry for your inconvenience. Could you please contact our Australia office and there will be someone can take care your issue.

 

Thermaltake Australia and New Zealand Pty Ltd.

Unit 1, 49 Henderson Road Rowville Victoria 3178, Australia 

TEL : +61 (03) 9763-1622 

FAX : +61 (03) 9763-1677 
E-MAIL :
sales@thermaltake.com.au 
WWW :
http://www.thermaltake.com.au

 

Also you can report here:

https://www.facebook.com/Thermaltakeau/?fref=ts

http://my.ttesports.com/ctGeneral.aspx

Share this post


Link to post
Share on other sites

I have the same issue here.

I wrote Thermal Take Australia support center one week ago and still not response.

http://my.ttesports.com/ctgeneral.aspx

Frankly this is not way to threat the customer as a serious company.

Now I am looking some solution tips from the google or community forums.

 

I bought my BlackV2 mouse 1 month ago and not  responsive at major cases when I start the PC.

Not just Windows also I can not enter into BIOS

Sometimes it works as expected from respectable mouse from respectable  manufacturer.

By the way I have a lot of products from thermaltake and all was ok until this product. Big disappointed!

I installed the Command Center v1.018

I need help asap

 

 

by the way in this editor I can not copy/paste at all in spite of allowing it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now