Jump to content

Welcome to Tt Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

Note:
If you are experiencing technical difficulties with your registration process, or if you have not received a confirmation mail, please drop an e-mail to ttcommunity@thermaltake.com with your registered username/e-mail. We will sort out your request as soon as possible, sorry for any inconvenience

Photo

【VENTUS R Optical Gaming Mouse】Owner’s Club


  • Please log in to reply
68 replies to this topic

#1
Tt David

Tt David

    Senior Member

  • Administrators
  • 436 posts
  • LocationTaiwan

Tt-eSPORTS-VENTUS-R-Optical-Gaming-Mouse  

 

Tt eSPORTS, the energetic and powerful challenger announces the new VENTUS R Optical Gaming Mouse.

Featuring a PIXART PMW-3310 optical sensor with up to 5000 DPI,

the VENTUS R comes equipped with an ARM based 32bit microcontroller with 32KB flash memory,

5 programmable keys for 5 different gaming profiles and 256kb of on-board memory,

coupled with aerodynamic engineered air-through ventilation system and smart ergonomic design,

the VENTUS R provides a perfect balance between hand-to-mouse and touch-feel experience to meet all the performance needs of the gaming enthusiast.

 

 

VENTUS R Optical Gaming Mouse suggested price of USD34.99.

 

For more information on the VENTUS R Gaming Mouse, please visit:

http://www.ttesports...Page.aspx?p=232

 

Tt eSPORTS official website and community websites:

Tt eSPORTS official website: http://www.ttesports.com/

Tt eSPORTS product video link: http://www.youtube.com/user/TteSports

Tt eSPORTS Facebook Fan Page: https://www.facebook.com/TteSPORTS

Tt eSPORTS Instagram: http://instagram.com/ttesports

Tt eSPORTS Twitter: https://twitter.com/ttesports



#2
dddddouuce

dddddouuce

    Just Getting Started

  • Members
  • PipPip
  • 18 posts

You should add a lift off distance adjustment to the software. Lift off distance is currently too high.



#3
dddddouuce

dddddouuce

    Just Getting Started

  • Members
  • PipPip
  • 18 posts

Figured it out, it's not the lift off distance that is the problem. The mouse jitters when lifted. This is a bug in the firmware of the mouse.

 

I hope you guys bother to fix it. I do feel though that there is very little hope given the previous track record.



#4
Tt David

Tt David

    Senior Member

  • Administrators
  • 436 posts
  • LocationTaiwan

We will report this bug to our engineer. Thanks for your help.



#5
dddddouuce

dddddouuce

    Just Getting Started

  • Members
  • PipPip
  • 18 posts

Well at least there is some acknowledgement. I find it disconcerting that support email never so much as replied back.



#6
trustlove

trustlove

    Just Getting Started

  • Members
  • PipPip
  • 15 posts

Figured it out, it's not the lift off distance that is the problem. The mouse jitters when lifted. This is a bug in the firmware of the mouse.

 

I hope you guys bother to fix it. I do feel though that there is very little hope given the previous track record.

 

Yes this is a real issue that needs to be fixed, I've tried over 20 top gaming mice and I personally like the ventus R's shape the best. I will however be returning it very soon if this issue isn't being fixed, I was going to review this mouse on youtube and make sure you guys sold alot more but then noticing this LOD lag ruined it for me entirely. Can you get a fix for this within the next week? The issue is when initiating the sensor, or inbetween "un-initiating" and initiating it lags at this moment unlike anyother mouse. Easily detected if you hover the mouse around the minimum LOD and move it around. So on swipes and repositionings of the mouse it will lag and your shot will be off (cursor will jump) etc etc. If this issue didn't exist I'd declare this ventus r the best mouse on the market I'd personally try to get your sales up. But waiting years for a firmware fix I'll no longer have the mouse to be able to do so. Can you get this to your engineer and get us some feedback if it's going to be fixed? emailing support doesn't seem to get any answers.



#7
Tt David

Tt David

    Senior Member

  • Administrators
  • 436 posts
  • LocationTaiwan

Yes this is a real issue that needs to be fixed, I've tried over 20 top gaming mice and I personally like the ventus R's shape the best. I will however be returning it very soon if this issue isn't being fixed, I was going to review this mouse on youtube and make sure you guys sold alot more but then noticing this LOD lag ruined it for me entirely. Can you get a fix for this within the next week? The issue is when initiating the sensor, or inbetween "un-initiating" and initiating it lags at this moment unlike anyother mouse. Easily detected if you hover the mouse around the minimum LOD and move it around. So on swipes and repositionings of the mouse it will lag and your shot will be off (cursor will jump) etc etc. If this issue didn't exist I'd declare this ventus r the best mouse on the market I'd personally try to get your sales up. But waiting years for a firmware fix I'll no longer have the mouse to be able to do so. Can you get this to your engineer and get us some feedback if it's going to be fixed? emailing support doesn't seem to get any answers.

 

I've discussed with our engineer about it. We're afraid that the question is caused by the setting of the sensor, if we want to change the setting we may need to discuss with the sensor supplier



#8
MarcmarkS

MarcmarkS

    Beginner

  • Members
  • Pip
  • 1 posts

Hello,

This issue is reported by this review too

=> ...



" I noticed a very obnoxious lift-off distance problem while using the Ventus R on a hard surface. A cloth surface did help a bit, but the problem was not completely gone. During normal usage, I would lift a mouse five to 10mm before setting it back down. I would drag and lift the Ventus R off the surface, which stopped the mouse cursor from moving: this is normal. But when I brought it back down, the cursor would teleport back to its previous position as if I never moved the mouse at all.

 
I was able to confirm it was an issue with the mouse by testing it on three different computers. When the mouse was lifted, it seemed like the sensor was still picking up information from the surface. But for some reason, it was not registering the movement to the cursor in Windows. Once the mouse regained contact with the surface, the cursor teleported back to its original position as if the mouse had not been lifted at all. I was able to prevent this issue by having to lift the mouse 15 to 20mm off the surface.
 
This was not a good thing to have especially for a gaming grade peripheral. The PMW3310 is an excellent entry level optical sensor, but I had never encountered a problem like this with any other mice besides this 3310 implementation on the Ventus R. I hope this was just a problem with my copy of the mouse. If you have a Ventus R, please let me know how it performs for you. "
 
 

Does this issue affect all copies?



#9
dddddouuce

dddddouuce

    Just Getting Started

  • Members
  • PipPip
  • 18 posts

This issue affects all copies, all firmware versions.

 

Hello,

This issue is reported by this review too

=> http://benchmarkrevi...ouse-review/5/

 

Honestly if a reviewer being provided free samples points it out, then it's a big problem. He even noticed the lift off control option greyed out even though it's there in the software to be used.

 

Oh, and I forgot since I only found this after bringing it out of storage last week. Holding down the middle scroll wheel button MAKES ALL OTHER BUTTONS NOT WORK ON THE MOUSE UNTIL YOU LET GO OF THE MIDDLE MOUSE BUTTON. The only reason I only learned about it until now was because I never use the middle mouse button for anything.

 

This mouse has major issues that need to be addressed.



#10
trustlove

trustlove

    Just Getting Started

  • Members
  • PipPip
  • 15 posts

I've discussed with our engineer about it. We're afraid that the question is caused by the setting of the sensor, if we want to change the setting we may need to discuss with the sensor supplier

 

Sounds like your engineer is thinking you are talking about the LOD being too low or too high, which is not the case at all, the lift off distance is actually perfect, however the lag is a whole different matter and I doubt the setting of the sensor has anything to do with it, I'm 99.9% sure this is fixable through firmware as there is some bug causing a delay. Why make a product with a severe issue and not try your hardest to fix it? this has been reported on multiple forums and reviews, Maybe hire a new engineer? I don't know but fix the issue or quit making mice honestly. Ripping people off without putting on the box "this mouse has lag issues when lifting it off the pad" is just bad business especially when someone could fix the problem if effort was put into it.



#11
Tt David

Tt David

    Senior Member

  • Administrators
  • 436 posts
  • LocationTaiwan

Sounds like your engineer is thinking you are talking about the LOD being too low or too high, which is not the case at all, the lift off distance is actually perfect, however the lag is a whole different matter and I doubt the setting of the sensor has anything to do with it, I'm 99.9% sure this is fixable through firmware as there is some bug causing a delay. Why make a product with a severe issue and not try your hardest to fix it? this has been reported on multiple forums and reviews, Maybe hire a new engineer? I don't know but fix the issue or quit making mice honestly. Ripping people off without putting on the box "this mouse has lag issues when lifting it off the pad" is just bad business especially when someone could fix the problem if effort was put into it.

 

Really thanks for the suggestion. We will fix the software bug asap. 



#12
trustlove

trustlove

    Just Getting Started

  • Members
  • PipPip
  • 15 posts

Really thanks for the suggestion. We will fix the software bug asap. 

That's good to hear, Thanks for contacting the right people about fixing it, can you keep us informed here if the engineer solves the problem so we know to get the firmware update going or any news on the issue would be appreciated.



#13
trustlove

trustlove

    Just Getting Started

  • Members
  • PipPip
  • 15 posts

This issue affects all copies, all firmware versions.

 

 

Honestly if a reviewer being provided free samples points it out, then it's a big problem. He even noticed the lift off control option greyed out even though it's there in the software to be used.

 

Oh, and I forgot since I only found this after bringing it out of storage last week. Holding down the middle scroll wheel button MAKES ALL OTHER BUTTONS NOT WORK ON THE MOUSE UNTIL YOU LET GO OF THE MIDDLE MOUSE BUTTON. The only reason I only learned about it until now was because I never use the middle mouse button for anything.

 

This mouse has major issues that need to be addressed.

 

I can also confirm the middle mouse button bug causes ghosting between the other buttons, this issue should be fixed as well. Maybe you can kill two birds with one stone.



#14
Tt David

Tt David

    Senior Member

  • Administrators
  • 436 posts
  • LocationTaiwan

I can also confirm the middle mouse button bug causes ghosting between the other buttons, this issue should be fixed as well. Maybe you can kill two birds with one stone.

 

I'd like to make sure "the other buttons" means the buttons on the mouse or keyboard?



#15
dddddouuce

dddddouuce

    Just Getting Started

  • Members
  • PipPip
  • 18 posts

Mouse itself. It's very easily reproducible.



#16
trustlove

trustlove

    Just Getting Started

  • Members
  • PipPip
  • 15 posts

I'd like to make sure "the other buttons" means the buttons on the mouse or keyboard?

Yea the mouse itself, finalmouse just released a mouse called the scream one which had this issue I think with all the buttons they said they needed to come out with a firmware update for "anti-ghosting" of the buttons, basically meaning if one button is pressed the others will not work, on the ventus r however its just the middle button if you hold it down the other buttons "mouse1" "mouse2" will not work. Which actually causes issues in some games.

 

On a side note I received an email today from support saying a firmware release has been released that will fix the LOD issue, I sign on quick as possible to find out no update exists.. my firmware is current at 1.08, very disappointing. Also some bit about returning the mouse to get another one lol I am very clear in my email that this is a real issue with every ventus r.

 

Besides tt David on this forum who seems to really try to help, thermaltakes support seems to be very lazy and they use misdirection to pacify their customers. It's very sad that a business would be so unwilling to fix an issue with a product they sell, Imagine starting a mouse company and spending months developing a mouse. Then selling it and getting horrible feedback and being the guy to say "lets just keep selling them like this who cares?" Now I know thermaltake isn't a mouse company and they have other avenues but the mentality is the same. I personally would do ANYTHING in my power to fix the problem same-day or as soon as humanly possible.. Maybe as a respect thing or just having basic morals and actual "care" for the product I'm producing.

 

I'll give it a few more days then I'm returning the mouse, but not before making a review and as it sits the review will not help the sales of this mouse of any other mouse from thermaltake. On the flip side if the engineer is fixing the issue this could mean a very good review. We'll see.



#17
Tt David

Tt David

    Senior Member

  • Administrators
  • 436 posts
  • LocationTaiwan

Yea the mouse itself, finalmouse just released a mouse called the scream one which had this issue I think with all the buttons they said they needed to come out with a firmware update for "anti-ghosting" of the buttons, basically meaning if one button is pressed the others will not work, on the ventus r however its just the middle button if you hold it down the other buttons "mouse1" "mouse2" will not work. Which actually causes issues in some games.

 

On a side note I received an email today from support saying a firmware release has been released that will fix the LOD issue, I sign on quick as possible to find out no update exists.. my firmware is current at 1.08, very disappointing. Also some bit about returning the mouse to get another one lol I am very clear in my email that this is a real issue with every ventus r.

 

Besides tt David on this forum who seems to really try to help, thermaltakes support seems to be very lazy and they use misdirection to pacify their customers. It's very sad that a business would be so unwilling to fix an issue with a product they sell, Imagine starting a mouse company and spending months developing a mouse. Then selling it and getting horrible feedback and being the guy to say "lets just keep selling them like this who cares?" Now I know thermaltake isn't a mouse company and they have other avenues but the mentality is the same. I personally would do ANYTHING in my power to fix the problem same-day or as soon as humanly possible.. Maybe as a respect thing or just having basic morals and actual "care" for the product I'm producing.

 

I'll give it a few more days then I'm returning the mouse, but not before making a review and as it sits the review will not help the sales of this mouse of any other mouse from thermaltake. On the flip side if the engineer is fixing the issue this could mean a very good review. We'll see.

 

We have a new version on the command center: http://www.ttesports...enterv10230.rar

 

But it didn't seem to be fixed the Ventus R issue. We will try to follow up the software update with the engineer and hopefully they can do it faster. 



#18
dddddouuce

dddddouuce

    Just Getting Started

  • Members
  • PipPip
  • 18 posts

That one is just the link for the Black FP software(it's still 1.0230). Someone else linked 1.0232 somewhere in the tt esports forums. However, 1.0232 does not have a firmware update for the Ventus R(I already checked).



#19
kai

kai

    Beginner

  • Members
  • Pip
  • 1 posts

Hi,

my Ventus R cursor occasionally (4 times today) jumps on the screen.  Firmware 1.08 and Software 1.0.2.30 are installed. Anything i can do to minimize this effect?

Kai



#20
Tt David

Tt David

    Senior Member

  • Administrators
  • 436 posts
  • LocationTaiwan

Hi,

my Ventus R cursor occasionally (4 times today) jumps on the screen.  Firmware 1.08 and Software 1.0.2.30 are installed. Anything i can do to minimize this effect?

Kai

 

Could you make a video of the occasionally jumps? We'd like to check the problem is caused by the software or the mouse.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users