Jump to content

Welcome to Tt Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

Note:
If you are experiencing technical difficulties with your registration process, or if you have not received a confirmation mail, please drop an e-mail to ttcommunity@thermaltake.com with your registered username/e-mail. We will sort out your request as soon as possible, sorry for any inconvenience

Photo

【VENTUS R Optical Gaming Mouse】Owner’s Club


  • Please log in to reply
68 replies to this topic

#41
dddddouuce

dddddouuce

    Just Getting Started

  • Members
  • PipPip
  • 18 posts

I don't think its truly fixed because there's virtually no LOD and the problem still occurs when you have some LOD,

Yeah, firmware 1.09 only makes it so the lift-off distance slider works in the software. I downgraded to 1.07 & 1.08 and everything worked with the new software except for the lod slider. So it's just a band-aid for the issue at the moment.
  • diego santos fernandes likes this

#42
Tt David

Tt David

    Senior Member

  • Administrators
  • 441 posts
  • LocationTaiwan

Yeah, firmware 1.09 only makes it so the lift-off distance slider works in the software. I downgraded to 1.07 & 1.08 and everything worked with the new software except for the lod slider. So it's just a band-aid for the issue at the moment.

 

Could you please try this one: ...



#43
trustlove

trustlove

    Just Getting Started

  • Members
  • PipPip
  • 15 posts

Could you please try this one: ...

I tried the link, the link doesn't work, is it to a new version of firmware?



#44
Tt David

Tt David

    Senior Member

  • Administrators
  • 441 posts
  • LocationTaiwan

Sorry my bad, I've uploaded the new software to the other place. Please try this link:  

https://onedrive.liv...8&action=locate



#45
trustlove

trustlove

    Just Getting Started

  • Members
  • PipPip
  • 15 posts

Sorry my bad, I've uploaded the new software to the other place. Please try this link:  

https://onedrive.liv...8&action=locate

 

Just tried this, it updated firmware to 1.10 and DID fix the mouse3 bug.. now I can hold it down and still use the other buttons.. VERY NICE.

 

The band-aid of adjusting LOD really low does help greatly with the lag issue, but once that is fixed completely this mouse will be on a path to greatness. I want to thank you David for making them engineers fix these issues. I do hope there is still someone trying to figure out what line of code is causing the mouse to lag when using lift off.. keep us updated and link any new firmware as I check this forum all the time. Thanks!



#46
Tt David

Tt David

    Senior Member

  • Administrators
  • 441 posts
  • LocationTaiwan

Just tried this, it updated firmware to 1.10 and DID fix the mouse3 bug.. now I can hold it down and still use the other buttons.. VERY NICE.

 

The band-aid of adjusting LOD really low does help greatly with the lag issue, but once that is fixed completely this mouse will be on a path to greatness. I want to thank you David for making them engineers fix these issues. I do hope there is still someone trying to figure out what line of code is causing the mouse to lag when using lift off.. keep us updated and link any new firmware as I check this forum all the time. Thanks!

 

Really thanks for your feedback too! We will keep update our Command center and make our mice getting better :)



#47
dddddouuce

dddddouuce

    Just Getting Started

  • Members
  • PipPip
  • 18 posts
Okay, I can't really check if the lod bug is fixed yet because my Ventus R is disassembled atm. I can however check the buttons.

All the previous bugs relating to the scroll wheel seem to no longer be there.

Progress!

I do hope there is still someone trying to figure out what line of code is causing the mouse to lag when using lift off.

I just hope the ODM that makes this mouse realizes how big of a screw up this is(they probably never will). The Ventus R's sensor liftoff bug occurs on another 3310 sensor based mouse that the ODM produces for another brand.

Though it's on the brand to check if stuff actually works correctly.

#48
Tt David

Tt David

    Senior Member

  • Administrators
  • 441 posts
  • LocationTaiwan

Okay, I can't really check if the lod bug is fixed yet because my Ventus R is disassembled atm. I can however check the buttons.

All the previous bugs relating to the scroll wheel seem to no longer be there.

Progress!

I just hope the ODM that makes this mouse realizes how big of a screw up this is(they probably never will). The Ventus R's sensor liftoff bug occurs on another 3310 sensor based mouse that the ODM produces for another brand.

Though it's on the brand to check if stuff actually works correctly.

 

Thanks for your advice.  We will take more time on testing the next mouse 



#49
diego santos fernandes

diego santos fernandes

    Beginner

  • Members
  • Pip
  • 9 posts

In the ventus R in the new firmware update 1.10 in the software I leave the LOD in the medium low or high?



#50
diego santos fernandes

diego santos fernandes

    Beginner

  • Members
  • Pip
  • 9 posts

In firmware 1.10 new update I leave the LOD in the medium low or high?



#51
Tt David

Tt David

    Senior Member

  • Administrators
  • 441 posts
  • LocationTaiwan

In firmware 1.10 new update I leave the LOD in the medium low or high?

 

Choose whatever you want?



#52
diego santos fernandes

diego santos fernandes

    Beginner

  • Members
  • Pip
  • 9 posts

Escolha o que quiser?

OK 



#53
trustlove

trustlove

    Just Getting Started

  • Members
  • PipPip
  • 15 posts

In firmware 1.10 new update I leave the LOD in the medium low or high?

 

Well "some" players like to have a high LOD so they can still track while lifting the mouse, "MOST" players like a really low LOD so as soon as they take the mouse off the mousepad to reposition it, it stops tracking until you put it back down. For me having it extremely low is best on any mouse.

 

But with this mouse specifically it has a bug where if you are hovering the mouse and its tracking at all it will lag and jump so set it all the way low and hope it doesn't track at all on your lifts/swipes/etc until they fix the issue, then you can set it how you want.



#54
dddddouuce

dddddouuce

    Just Getting Started

  • Members
  • PipPip
  • 18 posts
Yeah, I was finally able to test it myself. Sensor bug is still there on 1.10, no changes there.

#55
diego santos fernandes

diego santos fernandes

    Beginner

  • Members
  • Pip
  • 9 posts

Bem, "alguns" jogadores gostam de ter um alto LOD para que eles ainda possam acompanhar ao levantar o mouse, "MOST" jogadores como um LOD muito baixo, logo que tirar o mouse do mouse para reposicioná-lo, ele pára de rastreamento até que você Colocá-lo de volta para baixo. Para mim tê-lo extremamente baixo é melhor em qualquer mouse.

 

Mas com este rato especificamente tem um erro onde se você estiver pairando o rato e seu seguimento em tudo ele retardará e saltará assim que ajustou-o toda a maneira baixa e espera que não segue em tudo em seus elevadores / swipes / etc até Eles corrigem o problema, então você pode configurá-lo como quiser.

How do I go back to firmware 1.08 ?



#56
diego santos fernandes

diego santos fernandes

    Beginner

  • Members
  • Pip
  • 9 posts

How do I go back to firmware 1.08 ?

I find it better with her feel more precision on the mouse



#57
trustlove

trustlove

    Just Getting Started

  • Members
  • PipPip
  • 15 posts

I'm starting to think the bug isn't a bug at all and there's something inside the mouse affecting the sensor because when the LOD is all the way low it doesn't jump when lifting and such its only if you can get it to hover just a bit so the sensor isn't being able to work fully.. Possibly they put a stamp or tape on the back of the sensor and when removed it might fix the problem.. can a engineer test this theory?



#58
dddddouuce

dddddouuce

    Just Getting Started

  • Members
  • PipPip
  • 18 posts
The black cloth tape draped over the sensor isn't going to have any effect on the lod.

#59
ReturnOfTheKing

ReturnOfTheKing

    Beginner

  • Members
  • Pip
  • 5 posts

Sorry my bad, I've uploaded the new software to the other place. Please try this link:  

https://onedrive.liv...8&action=locate

Can't download..



#60
diego santos fernandes

diego santos fernandes

    Beginner

  • Members
  • Pip
  • 9 posts

This last update is with some flaw because they took it out of the Air to be able to download? Are you going to bring another firmware or are you just going to have this 1.08?






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users