Jump to content

Welcome to Tt Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

Note:
If you are experiencing technical difficulties with your registration process, or if you have not received a confirmation mail, please drop an e-mail to ttcommunity@thermaltake.com with your registered username/e-mail. We will sort out your request as soon as possible, sorry for any inconvenience

Photo

Riing 12 LED RGB Radiator Fan TT Premium Edition - Software not that great

- - - - -

  • Please log in to reply
58 replies to this topic

#41
joshrosenthal

joshrosenthal

    Just Getting Started

  • Members
  • PipPip
  • 13 posts

hello. tried all the aforementioned fixes, doesnt work still. tried different versions of the software too, nothing. no rpm, cant control the speed etc. can only see the temps but idk if thats accurate. if i click the info button on the 1.0.1 software it takes me to a text document with these:

 

HWi32_GetVoltage:Core #0 VID = 1.11133

HWi32_GetClock:Core #0 Clock = 3300

 

question: does that mean the controller is actually communicating properly but its the software thats screwy? also i cant seem to find the version 2.1 etc of the software. if you click the download button on the site it downloads the 1.0.2 version and that doesnt work



#42
joshrosenthal

joshrosenthal

    Just Getting Started

  • Members
  • PipPip
  • 13 posts

can anyone link the newest software version? the 2.1++ versions?



#43
joshrosenthal

joshrosenthal

    Just Getting Started

  • Members
  • PipPip
  • 13 posts

or you guys can just sell the controller separately so 1. we dont have to buy another 3 pack just to get 2 controllers and 2. so we can replace the broken ones you send out. smh



#44
Badgerslayer7

Badgerslayer7

    Beginner

  • Members
  • Pip
  • 8 posts

This is the link to the latest software I believe. http://www.thermalta...n/download.html



#45
joshrosenthal

joshrosenthal

    Just Getting Started

  • Members
  • PipPip
  • 13 posts

This is the link to the latest software I believe. http://www.thermalta...n/download.html

says failed. server problem. but i tried this download before. it downloads the 1.0.2 version



#46
Badgerslayer7

Badgerslayer7

    Beginner

  • Members
  • Pip
  • 8 posts
That's where I downloaded my 2.1 version from. What browser are you using?

#47
Revan654

Revan654

    Beginner

  • Members
  • Pip
  • 2 posts

I have a bunch of Basic version of Premium edition fans (120). Before I go ahead and install them, does the new software work or not? I'm not going to go through install all the fans just to find out the software is completely useless.

 

How I have my radiators setup it's hard to remove some of my fans due to all the tight space.

 

Whats the difference between these and the new Plus version other then what seems to be PWM and new controller box?



#48
joshrosenthal

joshrosenthal

    Just Getting Started

  • Members
  • PipPip
  • 13 posts

That's where I downloaded my 2.1 version from. What browser are you using?

chrome. is that the problem? ill try another

 

 

I have a bunch of Basic version of Premium edition fans (120). Before I go ahead and install them, does the new software work or not? I'm not going to go through install all the fans just to find out the software is completely useless.

 

How I have my radiators setup it's hard to remove some of my fans due to all the tight space.

 

Whats the difference between these and the new Plus version other then what seems to be PWM and new controller box?

 

 you wont know unless you connect em all. try it first with the fans out just the connections. if it works then take your rig apart



#49
joshrosenthal

joshrosenthal

    Just Getting Started

  • Members
  • PipPip
  • 13 posts

That's where I downloaded my 2.1 version from. What browser are you using?

 

btw does it say version 2.1 in the software? 



#50
Badgerslayer7

Badgerslayer7

    Beginner

  • Members
  • Pip
  • 8 posts
The link seems broken. I think mine says it's version v2.0.1 in the software. Cant check till Friday as I'm working away this week. Have you tried contacting support. The software seems to working ok with my system.

#51
joshrosenthal

joshrosenthal

    Just Getting Started

  • Members
  • PipPip
  • 13 posts

yeah works for some people. was working for me for about a month and a half. then suddenly nothing


  • beven32 likes this

#52
Badgerslayer7

Badgerslayer7

    Beginner

  • Members
  • Pip
  • 8 posts
The links working now. It's definitely version 2.1. It actually says v 2.1.2 in the software.

#53
joshrosenthal

joshrosenthal

    Just Getting Started

  • Members
  • PipPip
  • 13 posts

The links working now. It's definitely version 2.1. It actually says v 2.1.2 in the software.

 

thanks man trying now



#54
beven32

beven32

    Just Getting Started

  • Members
  • PipPip
  • 17 posts

yeah works for some people. was working for me for about a month and a half. then suddenly nothing

Is it just crashing over and over ?



#55
beven32

beven32

    Just Getting Started

  • Members
  • PipPip
  • 17 posts

The software was working good for a month or so and now it just crashes over and over. I have reinstalled windows so it must be crashing on the newest windows 10 build. Last windows update must have screwed us.

 

Please TT Update you're sofware again so my pc stops overheating and leaking !



#56
joshrosenthal

joshrosenthal

    Just Getting Started

  • Members
  • PipPip
  • 13 posts

Is it just crashing over and over ?

 

nope. just stopped working. was working for a month and then just stopped. was able to talk a bit to thermalmike. he said most prolly its the controller thats broken



#57
Jedson3614

Jedson3614

    Just Getting Started

  • Members
  • PipPip
  • 17 posts
  • LocationNY

I can tell you something that might work but only if you do NOT have Windows 10 Anniversary update installed. I know the latest OS who would think anyone would use that! I had these fans before I just got the Riing Plus ones, and that is an even bigger mess. The software doesn't work period, 0 RPM, no ability to change RGB colors, and no controller identified. The XML file is not the entire picture, if you have Windows 10 RTM and NOT anniversary update, then delete the XML file, reinstall program, and then go find the TT folder under program files and find the icon labelled HID and set this to Windows 8 compatibility mode, this temporarily gets the software to recognize the fans until reboot.

 

I know this isn't a fix but at least you can even get the software working at all. The thing I can't figure out for the life of me is why or what Windows 10 Anniversary update brings that breaks this software 100%. The software is built on Hardware Monitor so please TT open up the software for the community to fix.



#58
Jedson3614

Jedson3614

    Just Getting Started

  • Members
  • PipPip
  • 17 posts
  • LocationNY
I fixed my issue if you want the fix pm me!

#59
beven32

beven32

    Just Getting Started

  • Members
  • PipPip
  • 17 posts
Still waiting for a update TT... The 2.1.0v worked fine until a windows update causes it to crash all the time..
 
For me and my hard loop cooling it has made it leak twice. with no software my fans do not turn up and my loop gets to hot and pops out a fitting and leaks everywhere. So I am not being picky. This is a big issue... To call these usb fan controllers reliable you must first assure constant pwm control over the fans. Otherwise I should just go buy some cheap fans plug em on to mobo and let bios run fan pwm. 
 
I need stability #### !

Attached Images

  • 20170302_112335.jpg
  • 20170302_113334.jpg





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users