Jump to content
Sign in to follow this  
Junioretc

Riing 12 LED RGB TT Premium

Recommended Posts

Hi Thermal Mike. 

I purchased a set of the premium Riing 12 RGB fans (actually 2 sets) and installed the fans and controller. 

The controller has the molex power connected and the usb cable is connect to the mother bother to the USB 9 pin heade 

(I tried both USB 1314 and USB 1112). 

 

Also installed the Software downloaded from the Thermaltake office website. 

I am not able to control or read any stats from the software.

 

Upon firing up the software, there is an error saying "Riing RGBFan HID" has stopped. 

I am using windows 10 and the motherboard I am using is the ASUS Maximus VIII Formula.

 I tried just single controller (yes I did check the dip switch). 

Also I tried plug/unplug the usb cable to the controller and windows seems to detects the change of device configuration; 

so the USB connection (physically) between the controller and the MB appears to be okay.

 

I am wondering what would be the problem. Please help and let me know if more detail is required. 

 

Thanks Henry

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×