Jump to content
Sign in to follow this  
Juantrox

TTK Riing 12 RGB Fan not working properly

Recommended Posts

Hi guys,

 

Just finished my build with a 360mm radiator that has 3 ttk riing fans mounted. All three fans are connected to the TTK riing controller and the controller is connected to one my Sys_Fan connectos in the MB. The problem is that one of the fans will not start spinning when I turn on the computer. It looks like it tries and moves like a 1/4 spin but it stops. I also testing changing the speed in the controlled with the same result and finally I gave it a little push and it did spin a bit but after a couple mins it stopped. I also connecting the fans in differente places within the controller and in the mother board just to get the same result. Any ideas?

 

Cheers,

Juan

Share this post


Link to post
Share on other sites

Bump. 

 

Please respond Thermaltake, as I am experiencing the same problem!

 

- The button controller does not respond to any clicks (ie. Speed wont change, colours wont cycle, play/pause does nothing).

- Quite occasionally 2/3 fans will not spin. Likewise to previous user, they will attempt a 1/4 spin and eventually just stop altogether.

- With a push start, they will start spinning. I dont particularly want to open my case every time I turn on my PC!!

 

Would these be characteristics of a faulty controller???

 

I look forward to hearing from you,

Chris

Share this post


Link to post
Share on other sites

Hi

I am also experiencing a problem with the Riing fans that came with my Thermaltake View31 chassis. Sometimes 1 or more fans just stop spinning!

 

I either have to reboot or adjust the fan speen on my motherboard software to get the fans to spin up again.

 

Please help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×