Jump to content
Sign in to follow this  
SunflowerTwix

Theron Gaming Mouse - "Please plug-in Gaming Device to start the AP Configuration !"

Recommended Posts

So I'm really upset right now. I have owned 3 mice in my PC gaming history, and this, a brand new mouse can't even #### work properly? How handy is that? Huh? Right. Well let's jump into this.

 

Firstly, YES, I've tried this mouse in other computers and had the same result, YES, I've tried plugging it into other ports, YES, I've #### disabled and uninstalled the mouse via Device Manager (though it doesn't matter, since Windows #### REINSTALLS ITS OWN DRIVER ANYWAY! Some HID-compliant ####).

 

So without those 'fixes' out of the way, (regardless there's always that one #### that says them anyway) let's get into this, shall we? Since I'm not the only poor sod who's having this #### issue.

 

1. Wait 2 weeks for mouse to arrive via post.

2. Plug mouse in (after reading through paperwork and also finding out there's no driver disc. No problem, you can download them)

3. Oh snap! Which one do I download and from where? The website is less help than some dodgy Russian website which ends in .####

4. Manage to find Tt eSPORTS official drivers via these forums. Several versions of course. 2 of which lead to dead links, 1 of which when opened gives me the option to click "Recovery". Ironically BSoD's my PC. (Yes I tried several times, even in safe mode) So that's out of the question. The one I managed to find, kept coming up with an error containing "Please plug-in Gaming Device...etc" So that wasn't helpful. Later found an updated one where it's called "Tt eSPORTS Command Center" well...that installs. But that's it. It runs...doesn't open anything up, just runs idly in the taskbar. I double click it...nothing. I right click it, doesn't give me any useful options.

 

So I #### around in device manager, 'uninstall driver', restart PC, try again...rinse and repeat.

 

I am running Windows 7: Home Edition. 8GB RAM, GTX1070 GPU, Intel i5 CPU...etc etc. I don't have a #### PC. That's clear.

 

I apologize for my profanity to non Tt eSPORTS readers, since you have not been cause/effect of this issue. But come on Thermaltake people. Get your #### together. I paid $95.00AUD for this mouse and I'm about to ring up to return it as faulty or labeled as 'doesn't work as intended/advertised." SINCE IT #### DOESN'T! 

 

 

So tell me what the #### to do. Since this brand new mouse has all the problems in the world for Drivers (in which why is everything surrounding your drivers in #### Chinese? How is that going to be helpful to an 80% English speaking audience?). 

 

Yes btw. The mouse is functioning the exact same my $5.00 Microsoft mouse would. Except with forward and back buttons. Since I can't #### bind them SINCE I CAN'T #### OPEN THE SOFTWARE FOR IT!

 

Share this post


Link to post
Share on other sites

What you really have to love is its been 3 days an not a word.  I'm having the same issue with my VOLOS.

Could you please try this AP and reinstall the software again?

https://www.dropbox....1.0236.exe?dl=0

 

Reinstall AP

1. plug out your mouse

2. remove AP

3. go to C:\Program Files (x86)\Tt eSPORTS\ and clean all files 

4. restart your computer

5. plug in the mouse

6. install AP

 

Also please open the device manager and update driver software with this AP

L0Uhv.jpgIW9Lq.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×