Jump to content
themadtux

Riing.... Click click click....

Recommended Posts

I recently bought some 140mm RGB Riding fans for a new system I'm building. All's quiet save for one that makes a loud clicking noise while it's running. It still runs fine but the clicking can grate at the nerves.

Is there anything that I can do to remedy this issue? I will follow this up with a link to a video of the sound one I get back home.

On a side not is there something I'm missing with the controller for the fans? I shut the machine down and the color settings I have set aren't saving. Any suggestions?

 

EDIT: Here's a link to a video of the fan: https://youtu.be/M-sygEBK2TU

 

Thanks!

-Jason

Share this post


Link to post
Share on other sites

BUMP!  Anything on any of the issues I have?   The clicking or the fact that when I power off the machine the fans do not save their state?  I've tried multiple Riing fan hubs that come with them. 

 

THanks,

 

-Jason

Share this post


Link to post
Share on other sites

Hey dude, as far as I have read it looks like some motherboards don't supply enough power from the 4pin fan header to keep the colour settings, so connecting with a Molex to 4 pin power seems to solve the issue (in most cases)
 

Regarding the click.. that should be an RMA issue.. that's dreadful.

Inspect the fan, see if any fan blades look like there's something wrong, and maybe inspect the area for interference?

Share this post


Link to post
Share on other sites

Hey dude, as far as I have read it looks like some motherboards don't supply enough power from the 4pin fan header to keep the colour settings, so connecting with a Molex to 4 pin power seems to solve the issue (in most cases)

 

Regarding the click.. that should be an RMA issue.. that's dreadful.

Inspect the fan, see if any fan blades look like there's something wrong, and maybe inspect the area for interference?

 

You know I didn't even think of using a molex adapter.  Thanks for the tip.  Very much appreciated.  I'll do that and see how it goes. 

 

Yeah the fan drives me  crazy....  I'll have to see what I can do ...  I picked it up quite a while ago so I think an RMA is not a doable thing. :(

 

Thanks again,

 

-Jason

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×