The_Wizard_Man88

6 Riing Premium Fans - None Recognized by Software

17 posts in this topic

I bought six Riing premium fans for my build (2 packages of 3) and I currently have them all plugged into the two controllers. The controllers are then plugged into a single USB 2.0 header on the mother board using the split mini-USB cable. Neither of the controllers is recognized in the software and I can't control any of the fans.

 

The specs of my system are:

 

  • Intel 6700K
  • Asus Maximus IX Formula

 

What's going on? Why isn't the software recognizing these fans and how can I fix the issue?

Share this post


Link to post
Share on other sites

I am having the exact same issue and my fans are hooked up in the exact same manner. I have double checked the DIP switches and all connections. 

 

My specs:

Intel I7 6700k

Asus Maximus VIII Hero Alpha

Share this post


Link to post
Share on other sites

I have yet to find a solution, have you tried the controllers individually? I have tried that and uninstalling and reinstalling the software with no luck

Share this post


Link to post
Share on other sites

Submit a customer support request on the Thermaltake site, they got back to me within 24 hours. They asked me to troubleshoot a few things, but it with no luck. I believe they are going to end up sending me two new controllers.

Share this post


Link to post
Share on other sites

I am not sure, the first reply from them was almost 24 hours from my original message, just give it some time im sure they will get back with you.

Share this post


Link to post
Share on other sites

So to update this, after a fairly lengthy back and forth with Thermaltake they sent me two new controllers. Both controllers worked and the fans are now being read and controlled by the software. I'm happy they work, but I must say that getting two faulty controller units is a bit concerning.

Share this post


Link to post
Share on other sites

how'd you contact them? i have the exact same problem but mine are stuck on blue. what software are you guys running? i can only find links to 1.0.1 and 1.0.2. neither of them work

Share this post


Link to post
Share on other sites

And can you allow me take your work to our bbs and sharing with our Sudan FANS??I will tell them the work you made from where.

Share this post


Link to post
Share on other sites

how'd you contact them? i have the exact same problem but mine are stuck on blue. what software are you guys running? i can only find links to 1.0.1 and 1.0.2. neither of them work

I contacted them using the the online support contact (online email). They were very slow to respond, but eventually got back to me and then shipped out new units without a problem. I'm currently using v1.0.2 of the software. I believe there is a version 2.0.x of the software, but it just straight up doesn't work on my PC.

Share this post


Link to post
Share on other sites

And can you allow me take your work to our bbs and sharing with our Sudan FANS??I will tell them the work you made from where.

Sorry, I don't understand what you are asking?

Share this post


Link to post
Share on other sites

Well - there you go. Interesting to read that yet another person has also experienced multiple controllers that do not work (quality control gone down the drain?)

 

We have had nothing but problems with RIING RGB fans. Poor support beyond replacement of non-working controllers.

See full review on: http://community.thermaltake.com/index.php?/topic/63674-tt-premium-riing-software-controlled-fans-product-fail/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now