Jump to content

Welcome to Tt Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

Note:
If you are experiencing technical difficulties with your registration process, or if you have not received a confirmation mail, please drop an e-mail to ttcommunity@thermaltake.com with your registered username/e-mail. We will sort out your request as soon as possible, sorry for any inconvenience

Photo

RGB Riing PLUS Fans

- - - - -

  • Please log in to reply
3 replies to this topic

#1
cabchop

cabchop

    Beginner

  • Members
  • Pip
  • 2 posts

Hello forum.  First time poster.

 

Just purchased the Riing plus three pack of fans.  First impression:  These are gorgeous fans.  Wow.... is all I can say.  Still playing around with them, but so far very impressed.  

 

The controller and software seem to have a few bugs.  One issue I have noticed is I get a Controller Warning each time I make any change to the fan configuration and save it.  The configuration changes are saved, but a warning message pops up (image below).  The warning also pops up when I load the software.  I left the controller jumpers on default since I only have one.

 

I've also run into problems with my Corsair software since I installed the Riing Plus software.  The Corsair software (RGB for keyboard and mouse) does not operate anymore.  Not sure what the issue is but thought I'd check here to see.  Will continue to monitor and update.  Thanks.

 

 

Attached Images

  • 20170210_080359.jpg
  • 20170210_071451.jpg


#2
quincy314

quincy314

    Beginner

  • Members
  • Pip
  • 1 posts

try turning off fan 4 and 5 if you are not using 


  • cabchop likes this

#3
cabchop

cabchop

    Beginner

  • Members
  • Pip
  • 2 posts

try turning off fan 4 and 5 if you are not using 

Thanks for the advice.  Worked perfectly.  Didnt even know they were on until I read your post.

 

Much appreciated.



#4
Jedson3614

Jedson3614

    Just Getting Started

  • Members
  • PipPip
  • 10 posts
  • LocationNY

My fans spin, power up, and display RGB, but the software is unresponsive, I get 0 RPM and have no ability to change any colors. I have done a bit of research into these fans and the previous ones. Have any of you experienced these issues, or found a work around!






2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users