Jump to content
Fr0stbyte

Macros not working on Poseidon Z RGB

Recommended Posts

Suddenly my macros stopped working on my Poseidon Z RGB. I tried updating the software and firmware. Uninstalled, unplugged, reinstalled, repeat, etc. So it's basically busted. How can I get macros working again?

 

I wouldn't be surprised if its an issue with the software. As it looks as if it was just thrown together, so many typos and crashes with the software.

 

EDIT: Trying to apply macros time and time again, hoping it would somehow work, I've encountered a new problem. At times the whole keyboard will screw up and not even type until I hit the refresh icon in the software, therefore resetting everything.

 

Btw, I HAVE tried the following: 

Reinstall step

1. plug out your keyboard

2. remove AP

3. go to C:\Program Files (x86)\TteSPORTS and clean all files

4. restart your computer

5. plug in the Keyboard

6. install AP

 

Also, as you can see in the video I posted, I'm doing everything right. The macro commands SHOULD start appearing in Notepad as they used to, but they don't.

 

www.youtube.com/watch?v=PBnnwJEFqS8

Share this post


Link to post
Share on other sites

Sorry that our software doesn't allow to set the macro on "Fn" & "Application key"  because it may cause some problem on the system

 

Could you try to set the macro on other keys?

Share this post


Link to post
Share on other sites

I did that exactly. The only difference I see is that yours says "T key" (like in the older version of my software), where the newer version of the software I have it says "Macro key".

 

Still not works?

Share this post


Link to post
Share on other sites

Nope, still not working. =/ I had to buy a logitech mouse to use macros on... would still like for the keyboard macros to work eventually, though. They were easier to turn on and off.

 

I'm sorry that I really can't find the reason why it doesn't work on your PC. I've tried many Poseidon Z RGB keyboards on WIN 7 & WIN 10 and the macro works very well.....

Share this post


Link to post
Share on other sites

I cannot define the macro I require. I'm trying to record a macro that will output the following:

L@ss20

What I get (after assigning the macro to the F2 key) is:

lss20

Note:

1. The lower case L at the start, and

2. The @ symbol failing to output

 

Attached is a screenshot of the recorded macro, and an .ini file of the recorded macro.

 

My environment is Windows 10, using latest version (2.1.2) with firmware version 51.

 

Thanks for your help...

Macro7.ini

Macro7 - 1.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×