Sign in to follow this  
Followers 0
Botee

TT Riing 12 RGB Premium - Startup UAC

8 posts in this topic

if you dont run the TT controller software the fans will just spin at 400rpm(if its set at PWM+Performance mode).

thats why some people has problems with overheating because their fan rpm is not ramping up.

 

i noticed with when doing stress testing and gaming. the whole time my TT ring premium fans are jsut spinning at 350-400rpm the whole time.

when  run the software, the fans then spins up to 700-1000 to control the temperatute.

 

so i really need to run the software at startup. but its annoying because it triggers the UAC.

i cant turn off UAC because its not advisable to turn it off

 

attached pic is how slow the fan rpm is when im at desktop use and when the software is not running.

 

ps. my temp is 33c as seen in the screenshot. when gaming and stresstesting my max temps are only 50-55c (aio is 240mm rad)

i5-6600k @4.4ghz 1.35v delidded it.

 

 

http://imgur.com/7hq7vCe

post-109187-0-62414600-1489251715_thumb.png

Share this post


Link to post
Share on other sites

Unfortunately software is crap.

Mine starts up automatic in maximized mode. I have UAC off since I don't like the windows intrusion (contrary to recommendation).

I still don't understand why software has to start in full mode. 

And yes - if it doesn't - you'll fry your loop if you run watercooled.

 

The annoying thing is counterbalanced by the fact that once in a while you may get so annoyed that you try to close the Thermaltake Window (so it goes into tray) only to realize it has frozen up. Best thing is if it freezes at high RPM and then you can play your games and enjoy the tornado from the fans.

 

If it freezes at 350 RPM - then you will boil tea-water in your water-cooled system.

 

My only suggestion - turn it on manually or disable UAC. 

 

 

Share this post


Link to post
Share on other sites

yeah im starting to regret buying this already.

 

the work around i did was saved my profile to run the fans at 900rpm or 60% (its still silent so its ok) and turned off the performance, silent, and pwm mode. just lock it at 900rpm. saved and turned off computer. so when i start up my computer the fans really just at 900rpm. i dont need to turn on the bloatware again.

Share this post


Link to post
Share on other sites

yeah im starting to regret buying this already.

 

the work around i did was saved my profile to run the fans at 900rpm or 60% (its still silent so its ok) and turned off the performance, silent, and pwm mode. just lock it at 900rpm. saved and turned off computer. so when i start up my computer the fans really just at 900rpm. i dont need to turn on the bloatware again.

 

Yes, I've done the same to make sure they work. I can't believe how poor the support is and how poorly they (don't) respond to emails. 

I used to have a lot of acqutuning from aquacomputer I believe they were called some 7 years ago - and boy - the interaction from the LCD controller and software for multiple fans, RGB lighting, temperature, pump speed etc was so much better - and that was 7 years ago!!

Share this post


Link to post
Share on other sites

Guys I have fixed this problem and TT is aware of it, go to your roaming profile and find the Riign folder delete the XML file, also find HID under the TT programs folder and set to wWindows 8 compatibilities. This allowed my fans to stay consistent and no freezes work through fresh boots.

 

I get your frustration as these fans were expensive and NO I'm not telling you to buy new fans, but these problems with the software and such have been corrected with the new Plus fans. if I were you I would contact TT and ask if you can get them swapped out for the newer fans, It does not hurt to ask because the older Premium fans do have software issues. I have fixed them before but ultimately there are little bugs that are annoying and I do believe they are trying to focus on the new fans. They do care about their customers trust me. I work with them a lot and was just at PAX East with the TT team. I write reviews for them and have both reviewed the Premium and Plus fans already.

Share this post


Link to post
Share on other sites

Guys I have fixed this problem and TT is aware of it, go to your roaming profile and find the Riign folder delete the XML file, also find HID under the TT programs folder and set to wWindows 8 compatibilities. This allowed my fans to stay consistent and no freezes work through fresh boots.

 

I get your frustration as these fans were expensive and NO I'm not telling you to buy new fans, but these problems with the software and such have been corrected with the new Plus fans. if I were you I would contact TT and ask if you can get them swapped out for the newer fans, It does not hurt to ask because the older Premium fans do have software issues. I have fixed them before but ultimately there are little bugs that are annoying and I do believe they are trying to focus on the new fans. They do care about their customers trust me. I work with them a lot and was just at PAX East with the TT team. I write reviews for them and have both reviewed the Premium and Plus fans already.

The plus fans' software doesn't function correctly either. I can't even get it to run at all.

Share this post


Link to post
Share on other sites

Guys I have fixed this problem and TT is aware of it, go to your roaming profile and find the Riign folder delete the XML file, also find HID under the TT programs folder and set to wWindows 8 compatibilities. This allowed my fans to stay consistent and no freezes work through fresh boots.

 

I get your frustration as these fans were expensive and NO I'm not telling you to buy new fans, but these problems with the software and such have been corrected with the new Plus fans. if I were you I would contact TT and ask if you can get them swapped out for the newer fans, It does not hurt to ask because the older Premium fans do have software issues. I have fixed them before but ultimately there are little bugs that are annoying and I do believe they are trying to focus on the new fans. They do care about their customers trust me. I work with them a lot and was just at PAX East with the TT team. I write reviews for them and have both reviewed the Premium and Plus fans already.

if they would just update their software. i wont follow your suggestions becuase you already did their work for them.

 

let them fix it

Share this post


Link to post
Share on other sites

My riing plus software either causes my whole system to crash or it can't detect any fan. I don't even dare to re-download the software now. So scary. Either they help me solve the problem or I will return the fans. I should have buy nzxt instead of this piece of crap.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0