Jump to content
westlockfiredept

Can't get audio mode working

Recommended Posts

Hey folks:

 

Looking for a little advice. I recently completed my new build. Tower 900 running a dozen Riing Plus 12 fans for cooling. After a minor psychotic breakdown with trying to debug what I thought was a software issue(turned out to be a #### daisy chain cable) I have all 12 working in every mode but audio. It keeps telling me the audio source could not be received. What am I missing here? Aside from the audio issue. I have no complaints with fans

 

20170624_183544[1].jpg

Share this post


Link to post
Share on other sites

Downgrading your sound?  Are you actually mastering things at 24 bit to playback or are you under the assumption that somehow interpolating sound from 16 bit sources (most) to 24 bit somehow upgrades your sound?

I'm just as fed up with Thermaltake as the next guy, but unless your whole audio system is running 24 bit, including the source audio, then setting the Windows control panel default setting to 24 bit is gaining you nothing. ;)

####... Dolby's audio enhancement thing for laptops only works with 16 bit sound and that's Dolby...

Share this post


Link to post
Share on other sites

I noticed that you have an Asus Maximus IX that has  Supreme FX audio chipset, that means you might also  have the ROG Sonic Studio 3 software installed.  Try uninstalling SS3 and reboot , you might find that Riing lights will suddenly work in sound mode. I don't think dropping down to 16bit audio will help but hey, give it a try I guess. TBH I'd rather have the  Sonic Studio installed anyway than have sound activated lights,  there may also be alternative studio applications that work similarly to SS3 that play nicely Riiing Plus.  Good Luck

Share this post


Link to post
Share on other sites

In addition, when I uninstalled a software called Nahimic VR, all of my riing LED fans finally received the sound signal from my MSI Gaming M7 motherboard RealTek HD audio.  Until I uninstalled the Nahimic VR software, they would only receive a sound signal from bluetooth headphones  with the Windows 10 playback device set to those headphones as the default device.

Westlockfiredept, I hope you find your quick fix from this topic forum.  I hope Thermaltake makes a software update to fix the issue. Best of luck.

Share this post


Link to post
Share on other sites

That makes sense!  as both these applications Sonic Studio 3 and Nahimic VR rely on the  Nahimic audio enhancement framework.  As a guess, I would say most embedded premium sound products  that are using the Realtek chip would be using this Nahimic sound 3D enhancement framework,  MSI and ASUS are two such examples.

I  could find precious little re: these fans not working with sound lighting effects. Either people have given up, don't care or maybe not many Riing RGB Plus fan controllers have being sold worldwide :o. I can't imagine that though, nor that only a few people  are having this particular issue,  it's  easily reproducible much like the issues with Ryzen MBs and Riing controllers.

That said, the ASUS AURA RGB software (which you would have with this motherboard) also  has a music lighting mode and behaves as expected with regards sound activated lighting no matter what device is receiving the  sound stream.  It relies on a LightingSevice.exe service and quite possibly this  loads before the the Nahimic framework loads.

In summary, there is just as much chance that the issue is related to Nahimic's framework as it is related to TT Riing Plus software!  but my money is on the way the Riing software has been implemented, since the AURA works fine and is not fussed as to who has control of the stream and runs as a service . As an aside, you could try previous iterations of Sonic Studio ie SS2 see if it helps.

Share this post


Link to post
Share on other sites

I was thinking about my last response. So here's a possible temporary solution for your issue assuming you have verified that the issue indeed  relates to Sonic Studio 3 or a similar  program relying on  the Nahimic framework.

With regards to SS3, there are 3 processes created  when its started  .... SS3Svc32.exe parent process which sporns a child process called SS3Svc64.exe ( task bar icon) a process called SonicSudio3.exe is started when you run the SS3 application interface. You can close out this SS3  application and exit the SS3 taskbar icon and all 3 processes should be gone. This should allow TT Plus to  gain access to the sound streams,  you can  then re-enable the SS3 software again and  it should all now work. These programs are all set to start at login and it seems that SS3 starts before TT Riing Plus but you can change this behavior by disabling SS3 in windows startup.

Query  the task scheduler to see what programs are set  to start when you log into your computer.  You should  see that TT Riing Plus software as well as Sonic Studio3 (or similar) are enabled on  startup.  The only control i think you have here is to stop it from auto starting by disabling it and you can do this by running the task manager and selecting  a tab called startup,  look for Sonic studio 3 and disable it.  This  won't affect the actual SS3 program, it just prevents it from auto starting and creating those processes at login  but guess what ! your  TT Riing software should now work with sound! 

You should be able to start SS3 normally after this making sure that your TT software has started properly and working . The  Riing software will remain working with sound  until  you close it out ie exit from the task bar icon. Since there is no other simple non third party method to set  startup order within the startup list of programs  the easiest way I could think of controlling this behavior  is to create a scheduled task. You should be able to create a task for SS3  that triggers at login for all users after a specific delay of say 30 secs and only runs when user logs in.

Then create the action of.... start a program "C:\Program Files\ASUSTeKcomputer.Inc\Sonic Suite 3\Foundation\SS3Svc32.exe" with arguments of /command OpenUI /start SonicStudioSystray the rest of the settings on other tabs you should be able to leave at default.  Test the task to ensure it starts stops okay and creates the processes SS3Svc32.exe and SS3Svc64.exe. Then reboot, it should all work now :)

 Also you may want to think about  unticking "Allow applications to take exclusive control of this device" in the sound properties for the device you want to work with TT Riing but may not be necessary.

 

Good luck  !!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×