Jump to content
Sign in to follow this  
what619

Challenger Prime RGB keyboard not recognised

Recommended Posts

Hi All,

I just bought the new challenger prime rgb keyboard and mosue combo.

I plugged it all in and it was working fine until i followed the instruction booklet and website to download the software. I downloaded the software and as it was installing the keyboard turned off and the install application froze about half way through. Needless to say that the install "stopped working" and ever since that the keyboard is unrecognised and not working.

I have tried going to device manager and uninstalling the keyboard, the "unkown usb device (set address failed)" and restarted the computer and nothing has worked.

Can anyone help with this issue? I cant even re-install the software because it doesnt recognise the keyboard is plugged in.

Thanks

Share this post


Link to post
Share on other sites
On 30/8/2017 at 2:20 AM, Tt David said:

Did you try the keyboard on the other computer?

I have the same issue, but on others computers works fine, only on mine not work. what could be?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×