Jump to content
303 riing

Riing Plus fan looks slow

Recommended Posts

I have 2 sets of the Riing Plus fans and absolutely love them. Look amazing! However, one of my six fans looks slow. Under light I can see shadow of fans spinning whereas the others I cant' tell that there is blades spinning. (does that make sense?) The software says it is running at 80% speed, like all the others, but why does it look different? 

I'm wondering if I can replace one fan? I spent $35/fan and don't want to have a faulty one in the system. Any feedback would help.

btw, they are spinning at ~1250rpm so I can't take a photo to show you. But with human eye I can see the shadow of blades and it drives me nuts.

Share this post


Link to post
Share on other sites

Hi,

Check the connections on the fan to the controller. Swap the cable to another port, see if issue continue or stops. (Does the same fan do it no matter which port you know?)

Also, maybe before you warranty it, swap the fan with another in the chassis and see if the "visual change" you are seeing follows or stays.

If it concerns you, then contact us or your place of purchase to swap it out under warranty or what the retailer offers depending on your region and policy's.

http://www.thermaltake.com/corporate.aspx?t=4

 

Share this post


Link to post
Share on other sites

 

On 11/8/2017 at 8:04 AM, ThermalMike said:

Hi,

Check the connections on the fan to the controller. Swap the cable to another port, see if issue continue or stops. (Does the same fan do it no matter which port you know?)

Also, maybe before you warranty it, swap the fan with another in the chassis and see if the "visual change" you are seeing follows or stays.

If it concerns you, then contact us or your place of purchase to swap it out under warranty or what the retailer offers depending on your region and policy's.

http://www.thermaltake.com/corporate.aspx?t=4

 

Thanks for your response. I swapped the fan to another port and it looks the same. I also tried swapping to a different location but it looks the same. Seems to spin slower, as I see shadow but software says it is functioning as should. 

I live in Taiwan. Is there a store I could take it to? The store I bought the packs from will direct me to Thermaltake for issues. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×