Jump to content
rageoffreys

Floe Riing RGB 360 pump whine

Recommended Posts

Hi,

Try pick up your case and shift it around a little, that sound is likely a bubble and if you can allow the coolant to move around it should clear up.

Check your temps most of all to make sure the pump is working properly.

Tap on the pump with your finger a few times see if it helps.

If it continues, warranty would be better done sooner than later imo so you can get it swapped out, this is not normal.

Share this post


Link to post
Share on other sites

Thanks Mike, will give that a go. 

Temps seem fine, so the pump is definitely working. 

Would a bubble cause a whine though? I remember a very different noise when first using the cooler as the bubbles seemed to clear, this is definitely something different. 

I'll post a video later and you can be the judge. 

Cheers! 

Share this post


Link to post
Share on other sites

So a bit more context as I've seem to narrow down the issue. 

When I go into my BIOS and adjust the CPU fan speeds manually, I'm able to reduce the whine or remove it entirely if I bring down the levels low enough. 

I also tested the noise at 100% and the whine gets considerably worse. Any help much appreciated!

Share this post


Link to post
Share on other sites

Hi,

Thank you for the video, from the video that you provided, it sounds normal. That is the pump noise, it does not sound like it is defective to me.

Maybe different if I was there, no sure.

If you are concerned about it, just swap it with place of purchase or warranty it with us.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×