Jump to content

Welcome to Tt Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

Note:
If you are experiencing technical difficulties with your registration process, or if you have not received a confirmation mail, please drop an e-mail to ttcommunity@thermaltake.com with your registered username/e-mail. We will sort out your request as soon as possible, sorry for any inconvenience

【CHALLENGER Ultimate】Owner’s Club


  • Please log in to reply
16 replies to this topic

#1
Guest_Tt Paul_*

Guest_Tt Paul_*
  • Guests

The CHALLENGER Ultimate gaming keyboard is the highest end keyboard from the CHALLENGER series. True to the CHALLENGER name, the CHALLENGER Ultimate has cooling fans – but this time there’s more of everything: more colors for back-lighting, more macro keys with both dedicated and definable macro keys, more connectivity with a built in sound card.



#2
john paul

john paul

    Beginner

  • Members
  • Pip
  • 9 posts

since i plug in and install the driver i cant hear any sound...youtube,media player etc [sound problem solved]

 

uhm second problem when i first switch to profiles P1 to 5 always appears but now its gone



#3
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

since i plug in and install the driver i cant hear any sound...youtube,media player etc [sound problem solved]

 

uhm second problem when i first switch to profiles P1 to 5 always appears but now its gone

Hey John, did you try to reinstall the software again? If not, try to uninstall the previous one and reinstall again and see whether it helps.

 

Software as below:

 

CHALLENGER_ULTIMATE_VER2.0.2.0R

 

Keep us updated! ;)



#4
john paul

john paul

    Beginner

  • Members
  • Pip
  • 9 posts

P1 to P5 only appears only when i open the software of the keyboard but when its closed my only reference is the color on my keyboard



#5
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

P1 to P5 only appears only when i open the software of the keyboard but when its closed my only reference is the color on my keyboard

Hey John, did you ensure that you save the setting after you programmed the macro?

 

You will need to ensure you apply the setting before you close the software.

 

Please click the BOX framed (see photo below) after you complete the macro. ;)

 

Image 015.png



#6
john paul

john paul

    Beginner

  • Members
  • Pip
  • 9 posts

yes macros are doing fine, i mean when i open that and change profile theres P1 to P5 logo at the bottom of the screen and when i close the driver cant see p1 to p5..

just found out that you have to connect the speaker to the keyboard and not the computer to enable the sound it install its own sound driver i think?



#7
john paul

john paul

    Beginner

  • Members
  • Pip
  • 9 posts

trivial problems i think i'll just reffer to the color, i just wish they made the palm rest a little bit longer just like mecha g unit but i like ultimate's design more, over all im satisfied with ultimate



#8
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

Hey John Paul,

 

If you wanted to have that showed on your screen, you will need to ensure that:

 

1) On the bottom right, right click the dragon icon, and choose enable OSD.



#9
john paul

john paul

    Beginner

  • Members
  • Pip
  • 9 posts

sorry for bothering again but suddenly my backspace isnt deleting text
in all browsers / dota2 / facebook ETC
try a different keyboard works out fine tried to plug my TT challenger ulti to a different machine but its still the same
by the way when i press backspace 2x it moves to the customize and control google chrome
any idea what happened to my keyboard? T__T



#10
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

sorry for bothering again but suddenly my backspace isnt deleting text
in all browsers / dota2 / facebook ETC
try a different keyboard works out fine tried to plug my TT challenger ulti to a different machine but its still the same
by the way when i press backspace 2x it moves to the customize and control google chrome
any idea what happened to my keyboard? T__T

which country are you from? we'll get our local customer support to assist you :)



#11
john paul

john paul

    Beginner

  • Members
  • Pip
  • 9 posts

philippines sir



#12
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

philippines sir

Please contact our customer support at cs2@thermaltake.com and we will have someone to assist you further on the issue.



#13
john paul

john paul

    Beginner

  • Members
  • Pip
  • 9 posts

thanks sir



#14
Guest_Tt Josh_*

Guest_Tt Josh_*
  • Guests

No worries ;)



#15
heisdeadjim

heisdeadjim

    Beginner

  • Members
  • Pip
  • 1 posts

Hey. Query.
 
I can't get the colour choice of the backlight to "stick".

 

https://thecafe.me/i...louroptions.bmp

 

I can toggle on or off the Tt logo. I can change the colour.

 

Press Apply so far so good. Press OK / Exit and it throws back to the default red.

 

So of course if I change the profile it stays that hue.

 

Win 7 Enterprise x64



#16
DieGoDaYnO

DieGoDaYnO

    Beginner

  • Members
  • Pip
  • 1 posts

Hi my name is Diego Giani and i have a problem!

I just bought a Challenger Pro gaming keyboard. It was awesome, until I discovered a feature or whatever it is that is bothering me. When I was playing Battlefield 4, and tried to press three specific buttons at the same time (LeftShift+W+1) it didn't work. I can press LeftShift+W+2 or any other three-button-combo, but for some reason LeftShift+W+1 does not work! I can even press RightShift+W+1.

So basically I can't sprint forward and switch to pistol/primary weapon at the same time, and that sucks! I thought I post this problem over here just in case somebody else is using the same keyboard and having problems with it.

 

I bought the keyboard has not even one week, and I'm with this problem. Someone had this same problem? Running on Windows 10, my friend had the same problem on your PC, bought the same keyboard!

 

 

Can someone help me?

I bought the keyboard has not even one week, and I'm with this problem. Someone had this same problem? Running on Windows 10, my friend had the same problem on your PC, bought the same keyboard!



#17
Tt David

Tt David

    Senior Member

  • Administrators
  • 441 posts
  • LocationTaiwan

This keyboard is not full anti-ghosting keys, so it may happen sometimes.

 

 

Attached Images

  • 擷取.PNG





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users