Sign in to follow this  
Followers 0
Guest Tt Paul

CHALLENGER Ultimat Owner Club

17 posts in this topic

The CHALLENGER Ultimate gaming keyboard is the highest end keyboard from the CHALLENGER series. True to the CHALLENGER name, the CHALLENGER Ultimate has cooling fans – but this time there’s more of everything: more colors for back-lighting, more macro keys with both dedicated and definable macro keys, more connectivity with a built in sound card.

Share this post


Link to post
Share on other sites

since i plug in and install the driver i cant hear any sound...youtube,media player etc [sound problem solved]

 

uhm second problem when i first switch to profiles P1 to 5 always appears but now its gone

Share this post


Link to post
Share on other sites

since i plug in and install the driver i cant hear any sound...youtube,media player etc [sound problem solved]

 

uhm second problem when i first switch to profiles P1 to 5 always appears but now its gone

Hey John, did you try to reinstall the software again? If not, try to uninstall the previous one and reinstall again and see whether it helps.

 

Software as below:

 

CHALLENGER_ULTIMATE_VER2.0.2.0R

 

Keep us updated! ;)

Share this post


Link to post
Share on other sites

P1 to P5 only appears only when i open the software of the keyboard but when its closed my only reference is the color on my keyboard

Hey John, did you ensure that you save the setting after you programmed the macro?

 

You will need to ensure you apply the setting before you close the software.

 

Please click the BOX framed (see photo below) after you complete the macro. ;)

 

post-1609-0-35725700-1427790936_thumb.png

Share this post


Link to post
Share on other sites

yes macros are doing fine, i mean when i open that and change profile theres P1 to P5 logo at the bottom of the screen and when i close the driver cant see p1 to p5..

just found out that you have to connect the speaker to the keyboard and not the computer to enable the sound it install its own sound driver i think?

Share this post


Link to post
Share on other sites

trivial problems i think i'll just reffer to the color, i just wish they made the palm rest a little bit longer just like mecha g unit but i like ultimate's design more, over all im satisfied with ultimate

Share this post


Link to post
Share on other sites

Hey John Paul,

 

If you wanted to have that showed on your screen, you will need to ensure that:

 

1) On the bottom right, right click the dragon icon, and choose enable OSD.

Share this post


Link to post
Share on other sites

sorry for bothering again but suddenly my backspace isnt deleting text
in all browsers / dota2 / facebook ETC
try a different keyboard works out fine tried to plug my TT challenger ulti to a different machine but its still the same
by the way when i press backspace 2x it moves to the customize and control google chrome
any idea what happened to my keyboard? T__T

Share this post


Link to post
Share on other sites

sorry for bothering again but suddenly my backspace isnt deleting text

in all browsers / dota2 / facebook ETC

try a different keyboard works out fine tried to plug my TT challenger ulti to a different machine but its still the same

by the way when i press backspace 2x it moves to the customize and control google chrome

any idea what happened to my keyboard? T__T

which country are you from? we'll get our local customer support to assist you :)

Share this post


Link to post
Share on other sites

philippines sir

Please contact our customer support at cs2@thermaltake.com and we will have someone to assist you further on the issue.

Share this post


Link to post
Share on other sites

Hi my name is Diego Giani and i have a problem!

I just bought a Challenger Pro gaming keyboard. It was awesome, until I discovered a feature or whatever it is that is bothering me. When I was playing Battlefield 4, and tried to press three specific buttons at the same time (LeftShift+W+1) it didn't work. I can press LeftShift+W+2 or any other three-button-combo, but for some reason LeftShift+W+1 does not work! I can even press RightShift+W+1.

So basically I can't sprint forward and switch to pistol/primary weapon at the same time, and that sucks! I thought I post this problem over here just in case somebody else is using the same keyboard and having problems with it.

 

I bought the keyboard has not even one week, and I'm with this problem. Someone had this same problem? Running on Windows 10, my friend had the same problem on your PC, bought the same keyboard!

 

 

Can someone help me?

I bought the keyboard has not even one week, and I'm with this problem. Someone had this same problem? Running on Windows 10, my friend had the same problem on your PC, bought the same keyboard!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0