Jump to content
  • Forum Statistics

    8,260
    Total Topics
    40,890
    Total Posts
  • Member Statistics

    46,272
    Total Members
    16,800
    Most Online
    ghvbnmkopadq
    Newest Member
    ghvbnmkopadq
    Joined

reapz

Members
  • Content Count

    5
  • Joined

  • Last visited


Reputation Activity

  1. Like
    reapz reacted to Pyro2677 in **ATTN Users with Thermaltake Riser Cables**   
    Auspost was probably the longest part I'm in QLD and took about a week to get to me. To be honest not sure if i am bothered to go through all the BS just to get a new cable (that may or may not work, so now i have a choice either not use my PC for the next few weeks or just bite the bullet and just spend a day changing my custom loop and cable management. Since the Australian RMA department have my details already because hey had sent me a replacement cable from the stock that doesn't work. They should've just sent one to me when this problem was noticed and the "new" cables were issued as my details of complaining about non working cables should be documented. Poor customer service and I don't think i will be buying another TT product again. If this cable has fried my GTX1070 you will definitely be hearing from me to have that replaced.
     
    To be honest I'm quite P1$$ed off about this Since i just finished my custom loop and ALL of the cable management and now I have to Remove it all so i can directly plug my GPU into the slot. The nerve of them saying it was either my 760 or old motherboard. I was emailing my Asrock asking them why it didn't work and also Gainward why the card wasn't working and NOW I findout it was TT's problem all along. There should be a worldwide product recall notice issued.  
×
×
  • Create New...