Jump to content


  • Posts

  • Joined

  • Last visited

Everything posted by Zagorath

  1. So I guess this is never getting updated then? Is that a safe assumption?
  2. You, Josh, are not ignoring users. You're not the problem. However, "you" in the broad sense, meaning Thermaltake, are clearly ignoring users. Because this problem has been ongoing for three years now and there is no appreciable work being done to fix it.
  3. It's been nearly two years since you said this, and at least three since the problem was first noticed. When is this going to get fixed? Besides, having Windows key work in gaming mode isn't what people want. We want macros to work in non-gaming mode. It would also be nice if the software made it clear what's what. Currently the software makes it appear as though there is one gaming mode and three regular modes, but actually it seems to be more like three gaming modes and one regular?
  4. I would also very much like to know when this problem is going to be fixed. It sounds like more or less the same problem I have been having. This software *really* needs to get updated.
  5. The Challenger Prime keyboard software has four profiles. One called Gaming Profile, and three called Profile 1-3. The problem is that they don't actually seem to work that way in practice. Pressing M1, M2, or M3 on the keyboard disables the Windows key. Pressing Fn+PrtScr (i.e., going to gaming mode) enables the Windows key again, and takes me to a profile that I don't seem to be able to control. Pressing Fn+PrtScr again takes me into the gaming mode profile I had set up in the software. My testing method is simple. I set up the T6 macro key as shown in the screenshot. Press M1 then T6, and it enters '1'. Press M2 and then T6, and it enters '2'. Press M3 and then T6, and it enters '3'. Press Fn+PrtScr and then T6 and it enters '' (i.e., nothing). Press Fn+PrtScr again, and it enters 'g'. The expected behaviour would be for M1, M2, and M3 to have the Windows key enabled, and pressing Fn+PrtScr to disable the Windows key and put it into the specified Gaming Profile. Or, failing that, for it to at least have M1-3 disable the Windows key, Fn+PrtScr to enable the Windows key and put it into the mode the software describes as Gaming Profile. Could anyone explain this behaviour to me, and how to fix it to perform as expected? Cheers.
  • Create New...