Jump to content

Search the Community

Showing results for tags 'Pump'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • LUXA2 Thermaltake Mobile
    • Power Bank Solution
    • Holder Solution
    • Audio Solution
    • Accessories
    • LUXA2 General Discussion
    • FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 4 results

  1. Hello there, I noticed that there is a lot of discussion about the noise level an aio pump creates. And i´ve done now a few days of research about my problem. About a month ago i bought my AIO and after installing it had no problems. Now a few days ago, my pump started to make a high pitch noise and a lower frequency rattling noise. I made an video of it for you to listen. The level varies from 52 to 60dB. And yes i tried everything, from books under the front and back of my case, moving the case, lay it on it´s side, and letting it stay for a few hours. Everything done while the pump was running. The pump runs as always on about 1825 rpm. The aio is top mounted. Today there has come up a few times an error message "Warning controller number 1", don´t know if it is related to the pump noise. But on the software is installed correctly, and the empty slot is deactivated. Like i said there was no problem before, and as the problems started, there happened nothing special. So what i wanted to know is if there is something else i could do, or is the pump going to fail? Should i replace the AIO? Here is the link to the video: Thank you very much for your help
  2. Hi!!! I'm thinking in buying the Thermaltake Commander FT (http://www.thermaltake.com/Cooler/Cooling_Accessory_/Fan_Controllor/C_00002651/Commander_FT_Touchscreen_Fan_Controller/design.htm) but i'm not sure if this one can control the speed of the pump of my liquid cooling system.. i have installed the Corsair Hydro H60 (http://www.corsair.com/en-gb/hydro-series-h60-high-performance-liquid-cpu-cooler) Does anyone have the Commander FT working with any kind of pump... or do you know if it might work with it??? Thank you!
  3. Hello All, I was wondering if it is possible to use two pumps/reservoirs on the Pacific LCS RL120 Kit. It seems that the biggest risk of LCS's is the pump failing, so would it be possible to use two PT20 Pump/reservoirs in a push/pull configuration? Thanks, GC
  4. Moisty

    Rl240 help

    Hi, I am after some help if you can help me out will be much appreciated . 1. I have rl240 kit and was wondering how do I drain the fluid? 2. I have anotger resovior that I would like to install as well, is this possible to run just off the pump/resovior that's in the rl240 or do I need another pump for the resovior? 3. I am getting like a residue water type stuff at the top of my rl240 pump /resocior its like in the air bit of there. Was wondering if that is normal? And is there a way to get rid of it? Thanks so much
×
×
  • Create New...