Jump to content

Search the Community

Showing results for tags 'Windows 7'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. I have been trying to get any of the multimedia keys on the Tt Challenger Prime to work but so far they don't seem to work on my new Windows 7 computer. I've tried changing usb slots, restarting the computer, and reinstaling the drivers for it with no results. It does however work on a laptop with Win XP I tested it on. How do I get it to work with my new computer?
  2. Hello, I installed the Max 5 Duo HDD bay in my Windows 7 computer, started Windows, placed a 3.5 2TB WD formatted HDD in the bay, closed the door, flipped the switch to the on position and .... nothing is happening. The light turns from solid blue to solid purple for a couple of seconds, and then it returns to a solid blue. Windows is not showing up the new HDD I have plugged this HDD inside my computer as a test, just like a regular HDD and Windows is happy to show me its contents. I have gone to the Disk Management screen in Windows and it shows no new drive either. I made sure that the connectors from the bay get inserted into the HDD when I close the bay door. Any help will be appreciated. Thanks Roberto
×
×
  • Create New...