Jump to content
marionette_66

HDD in Max 5 Duo is not recognized

Recommended Posts

Hello,

 

I installed the Max 5 Duo HDD bay in my Windows 7 computer, started Windows, placed a 3.5 2TB WD formatted HDD in the bay, closed the door, flipped the switch to the on position and .... nothing is happening. The light turns from solid blue to solid purple for a couple of seconds, and then it returns to a solid blue.

 

Windows is not showing up the new HDD

 

I have plugged this HDD inside my computer as a test, just like a regular HDD and Windows is happy to show me its contents.

 

I have gone to the Disk Management screen in Windows and it shows no new drive either.

 

I made sure that the connectors from the bay get inserted into the HDD when I close the bay door. 

 

Any help will be appreciated.

 

Thanks

Roberto

Share this post


Link to post
Share on other sites

Hello Roberto, 

 

Blue LED light indicates that there is power connected, so you wont be able to determine if it is working or not by looking at the LED
 
To help determine what problem is accruing, please try the following steps
 
1. Make sure that all cables are connected
2. Ensure the SATA cable is not damaged, you can change it to a 3.5-inch wire to test
3. Try with another good hard drive to test

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...