Jump to content
mrsensors

Tt 5G Duet and Mac OS Yosemite

Recommended Posts

"Thermaltake 5G Duet" keeps disconnecting on Mac OS X, with the latest Yosemite.


“Disk Not Ejected Properly†is usual message. It happens suddenly with no special reason.


I might copy something or do nothing at all. It may take 2 minutes, it may take 10 minutes till disconnection.


HDD are 3 Samsung drives from 2008. Working fine in the PC.


Drives ar NTFS,  and Mac OS Extended (Journaled)


 


I have tried:


- unchecking “put drives in sleep when possible†in Energy saving


- downloaded some wierd JMicron firmware update utility, which did nothing and is disabled on start, no matter do I add additional drives or leave enclosure empty.


- tried different drives in different combinations.


- read lots of forums on the internet about the problem, which is not unique for me, no help.


 


I am an IT professional, so your answer may get as technical as it needs to be.


 


Also, what similar product you would recommend, which worked on Mac OS, because I am about give up on this one?


Thank you.


post-9232-0-83078900-1435166587.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...