Jump to content

How do I remove Tt DPS G App_Global_Ver3.2.0


Recommended Posts

I have a Thermaltake Toughpower iRGBPLUS 1050w power supply. I decided to uninstall the software using the default windows 10 program uninstaller (Program and Feature option in the control panel). After rebooting I now get the error message  "The system cannot find the file Thermaltake DPS Power.exe". I have tried reinstalling then uninstalling again. I tried 2 different uninstallers apps to get rid of it. I also checked for services and the startup and did not find what was trying to run this app. I even looked in the environment variables to see if I could get a hint. How do I fix this.

ps error.jpg

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...