Jump to content

Issue with Thermaltake Riing Quad 120mm fans and TT RGB Plus


Recommended Posts

Hello everyone. I have an issue with the Riing Quad 120mm fans.

I bought two three packs from Amazon, with the controller. I have one controller set as 1 via the dip switches, and the second one set to 2 as per the manual.
I have fans plugged into 1, 2, and 3 on both controllers.


When I start up they rainbow just fine. When Windows loads, I get an error. When I open TT RGB Plus the fans are set up wrong. It sees a fan plugged into 5 that's not there, and it's missing the fan plugged into 2. I can correct this by hitting the power button on the 5th fan to turn it off, then again on the 2nd fan to turn it on. Change all the fans to be Riing Quad...and everything's fine. I do this for Controller 1 and 2. I click save, then to be sure I save that to every profile. 

When I reboot? I see TT RGB Plus pop up real fast, and all the fans say Lumi Plus, then it goes away. Then I get the same error again, and the wrong fans show up again just like before. It doesn't seem to save the settings. I run the program as admin and everything. Make sure to save my configuration, and reboot. Still....error. What can I do to fix this?

Hopefully these pics come in order, but they're pics of the fans, the right settings, the reboot pop up with the wrong settings, the pop up telling me error on controller 1, then opening it to different wrong set settings. 

PXL_20210108_020943898.jpg

PXL_20210108_020954315.jpg

PXL_20210108_021000568.jpg

PXL_20210108_021053069.jpg

PXL_20210108_021059326.jpg

PXL_20210108_021118728.jpg

PXL_20210108_021126095.jpg

PXL_20210108_021138931.jpg

Link to post
Share on other sites

On the download page, they have not removed v1.3.8 - that should be a HUGE clue on what to do!

I had the same problem. New Riing Trio 12 with controller. Installed it, loaded the software (1.3.9) and I thought my controller was bad. Any fan plugged into 1 worked. Any fan plugged into 3 mostly worked, but I would get the Exclamation Point of Doom on 5 - even with nothing plugged into it - along with the Controller 1 warning splash. I put a fan in spot 5 and sometimes it would work, sometimes it would error, sometimes I needed to reboot - - - a freakin nightmare. No combination seemed to work.

I uninstalled Thermaltake Tool 1.0 and TT RGB Plus 1.3.9, then deleted the folder "C:\Program Files\Tt", then deleted the folder "C:\Users\<Your Name Here>\Roaming\Tt". Rebooted, installed 1.3.8, and everything worked the first time, just like you'd expect.

I wasted about 6 hours on this and found the solution in another thread. It was a hard forehead smack to see the solution - it was right in front of me the whole time. Never saw it. Nice hardware, but without the corresponding software working it doesn't matter. The whole package winds up being bad.

Link to post
Share on other sites
49 minutes ago, Esphion said:

On the download page, they have not removed v1.3.8 - that should be a HUGE clue on what to do!<snip>, but without the corresponding software working it doesn't matter. The whole package winds up being bad.

Thank you! We'll try that. I hope 1.4 fixes all of it whenever it comes out too. 

Link to post
Share on other sites

Thermaltake RGB Riing Trio 120mm and TT RGB Plus wont retain settings.  Have to turn on every time windows restarts.  TT RBG won't save settings.  Riing Trio controller resets when windows restarts.

Hopefully the sentences above will show up in google search and save someone all the trouble I had.   Version 1.3.9 is garbage.  Can't even believe they haven't reverted back to a previous version.  The solution above (1.3.8) solved the problem for the most part but it still threw an error warning.  Thermaltake support replied and told me to try installing version 1.3.7 (https://bit.ly/TTRGBPlusV137) and it solved the issue.   As soon as windows starts my setting take effect every time and no issues with the software.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...