Jump to content

Tt eSPORTS SAPHIRA


col.phantom
 Share

Recommended Posts

Hello, today I want to post my feedback on the saphira mouse.

 

I have bought 2 of this mice, one for my brother and one for a friend, I tested them both, and this is what I think:

 

The hardware part is brilliant, the avago 3090 sensor is just a masterpiece and the switches, wheel and shape of the mouse are just spot on, the problem is the software. I dont know why thermaltake decided to make a different software for each peripheral, i have tried the black mouse too, and the software is just very weak and buggy, in the saphira software when i try to adjust the dpi it has to be done in a special manner because if you try to type in the dpi number it just doesnt save, the double click speed and the scroll speed slider just dont work, and if i save a polling rate value to the mouse it resets when i plug it in a different pc, I set it to 1000hz on my pc and when i plug it in my laptop it works at 125 or 500. The software gave me a windows error after instalation and the graphical design of it is just wrong.

 

The other problem with this mouse is the sensor, I dont get why it malfunctions so fast, this same sensor (3090) works flawlessly on other mice (spawn, g400, deathadder 3.5g) I can reach high speeds with those mice, but in the saphira it locks when I move it too fast, Ive tested this with a qck+ mousepad and with a wooden desk and it gives me the same result, it has to be a firmware error because this sensor is just perfect, the saphira is very accurate and works good, but it doesnt reach the same speeds as other mice with this sensor.

 

I have tested this mouse with different computers and versions of windows and it is always the same errors.

 

It has a minor bug too, the lock switch is bugged, when you flip the switch to lock the side buttons they still work.

 

 

post-397-0-84732100-1407434285_thumb.jpg

Link to comment
Share on other sites

  • 9 months later...

Hi col.phantom, I've already informed the team about this. Will update you on this once this has been reviewed.

 

Any news on that one? If so, was it FW or just problems with specific surfaces, or maybe problems with the LED used?

Link to comment
Share on other sites

Guest Tt Josh

It was never fixed AFAIK.

Hey woll3, as we are currently busy with COMPUTEX 2015, I will not be in the office for this week.

 

I'll check with the team once im back! ;)

Link to comment
Share on other sites

Guest Tt Josh

It was never fixed AFAIK.

Hey woll3, please contact our customer service at support@thermaltake.de.

 

We will have our local staff to assist you further.

Link to comment
Share on other sites

Hey woll3, please contact our customer service at support@thermaltake.de.

 

We will have our local staff to assist you further.

 

And German Support will write a new Firmware? :P

 

Well, i dont have my Saphira anymore but problems with the malfunction speed are also present in the Azurues(i still have one) which malfunctions at ~2.5m/s, while nearly everything else with A3080 achieves well over 3m/s. The problem is that Tt´s entire Lineup atm is a compromise, Azurues/Azurues Mini and Saphira have low malfunction speed, Black V2, Ventus/Ventus X have high Speed related Variance(Acceleration). Please dont see it as any kind of bashing, the shapes you have are really good, but ultimately one thing is wrong everytime.

Link to comment
Share on other sites

  • 7 months later...
Guest Tt Josh

Tt Josh, any update on the max speed issue?

Just checked with the team, and the issue has already been sent to the vendor, but there's no news regarding on the issue yet.

Link to comment
Share on other sites

  • 4 months later...
Guest Tt Josh

this is so bullshit this mouse is awesome but the scroll wheel #### up it so hard

Hi, please contact our support at rma@thermaltake.com.au and we will have someone to assist you accordingly  :)

Link to comment
Share on other sites

  • 1 month later...

Hi, I've been having issues with my computer and the mouse, ever since i got the mouse i've been getting random blue screens of death, i've installed the CD that came with it, does the firmware come with the CD or nah? cause I didn't realize that you had to install firmware.

I sound like a noob, damnit.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...