Jump to content

TOUGHRAM software 1.0.6 does not properly recognize TOUGHRAM RGB


Recommended Posts

As the topic says - I recently purchased a 32 gb pair of 3.600 clocked TOUGHRAM RGB sticks, inserted them into my motherboard, loaded the XMP profile and ...

... first dissapointment - the system does not even boot at this setting.

 

Second issue is that the software does not properly recognize the sticks - while there is a temperature mentioned at least, I cannot get the RGB stuff working. The attached screenshot shows what I see - the preview frame remains empty no matter what I try and there is a row with letters (from A to H) that interferes with the RGB sliders. Am I the only one with such issues? I tried NeonMaker as an alternative - but that tool does not even detect any supported hardware.

 

I´m using a rather new platform (B550 chipset, 5800X CPU). Maybe Thermaltake needs to awake and release a newer version of the tool? While surprisingly enough the platform is recommended for my RAM.

 

Any help is appreciated.

 

My setup is as following:

 

msi MEG B550 Unify-X, AMD Ryzen 7 5800X, Thermaltake ToughRAM RGB, Aorus GeForce RTX 3080 Master, Samsung 980 Pro, WD_Black, Enermax MaxTytan 1050, NZXT H710i

 

Toughram.Jpg

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...