Jump to content

Blacx 5G duet Windows 10 support

Recommended Posts

I just recently purchased Blacx Duet 5G. Having problems with Windows 10. 




Everything seems normal at first, but suddenly the transfer stops.




The dock will then disconnect, and cannot read the hard drive itself. When replugging the dock, my hard drive will then be on RAW partition. Any drivers or solution for this problem on Windows 10? It is working fine on Windows 7. Thanks.


Edit: I tried it on other hard drive enclosure and the drive is working fine, it can read/write with no problem.

Share this post

Link to post
Share on other sites

You made it a step further than I did on Windows 10. I just unboxed my "Thermaltake BlacX" today; tried using two separate hard drives (both of which I know work) -- and the drives do not show up under My PC... I do however see them listed under device manager.


Not sure how I'm supposed to access them...

Share this post

Link to post
Share on other sites

Still no help from Thermaltake on this? Whats going on with the industry as this seems like a dire trend going on (and worse made considering W10 was officially released in late Jul'15 and yet all h/w vendors had more than enough time to prepare).


I have the same 2-bay BlacX 5G USB3.0 on the latest Windows 10 Pro + v.high end MSI laptop and while my xfers with the docking station (has 2x 8TB Seagates in it working fine) I get strange pauses and controller errors being noted in the W10 Pro event viewer from time to time (every 20 seconds it does this). Xfer speeds are superb both ways: 180mb/sec I can max out copying from the dock to the laptop and the other way.


Mind you, if I plug in any kind of USB3.1 device I experience what the first poster has: it drops to 0 speed and the device turns off.. Weird.. copying the other way has no issues. I chalked this up as either immature W10 drivers, W10 itself, or the MSI laptop I have is still immature itself.

Share this post

Link to post
Share on other sites

Win 7 x64 Pro

Asrock A75 Pro4-M set to AHCI

Hitachi 3TB (brand spankin' new)


***note - I have a HD installed in this system that has never been initialized -call it "Sally" ***     VMware Training in Chennai    :P


Supposedly the dock is plug and play.   VMware Training in Chennai     :P


I have the USB version.

I plugged it in to a USB3 port, plugged in the HD and powered on the dock. 

Disk Manager - Up pops the new drive and Sally and I'm told to initialize for DM to work correctly.

I unchecked Sally so I can do the new drive only. Set it to NTFS. It starts the process and then says DM needs to be refreshed and then quickly drops back to the DM only. The format window is gone.

I can't see the new HD anymore.

Through a series of powering on and off both PC and dock I get the drive back but it is unformatted. 

Hit 'format'. It seems to work and then just stops. HD is not visible in DM.

Power on/off and I cannot see the new HD.


Connect the HD to the mobo and completely format it. I copy 1TB of data onto it. 


Power down. Take the new HD and plug it into the dock, power it on. NADA 

Not visible in DM or explorer. Any thoughts???


EDIT: As I'm typing this up I got a window that says the new drive needs to be formatted in order for it to work??? It is mos def formatted and has a TB of data on it!

Still not visible in DM or explorer.


Maybe an issue because it's a 3TB drive?   VMware Training in Chennai     :P

There is an update that I have not installed. Maybe I should do that...but I'm almost certain I read that it would work w/3TB drives. 

Share this post

Link to post
Share on other sites

Just got a blacx duet...  Also crashed with weird delay timeout and tool disconnex... however, i have a USB-C port and adapter on my Asus  laptop (Win10) That adapter works GREAT! I tested this right before taking it back to Best Buy..  

Share this post

Link to post
Share on other sites

I don't see a response from Staff of BlacX Duet -- just us newbies. Same problems: Windows 10, USB on both computer and BlacX Dual. Tried several HDDs. Initially, Windows tried to reformat my 4TB HDD into a 1 G format. Since then, nothing happens. It isn't visible anywhere.

Share this post

Link to post
Share on other sites

hi guys,

MyInsite: Macy’s organization is a unique American retail establishment. The organization, founded by Rowland Hussey Macy was previously known
by the name of R. H. Macy and Co. The organization was established on 28th October back in the year 1858. It has been almost 160 years in New York
City that it was first set up. The organization has its headquarters situated at Herald Square, New York City, the United States of America.
Starting in 2017, the organization works in 669 different areas.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now